Having problems with your 1997 Chevrolet K1500 ?

I have a 97 yukon and the trans shifts fine there are no codes that come up but the converter will lock and unlock while driving on the free way when i first got the truck it did it and the trans let go so i put in a used from my buddie which worked fine then he wrecked the his truck what could be the problem

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Sounds like the lock up selonoid is going bad. it is in the trans, have to remove the pan to get at it.
Repair Help & Product Troubleshooting for 1997 Chevrolet K1500

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a 97 yukon and the trans shifts fine there are no codes that come up but the converter will lock and unlock while driving on the free way when i first got the truck it did it and the trans let go so i put in a used from my buddie which worked fine then he wrecked the his truck what could be the problem


Sounds like the lock up selonoid is going bad. it is in the trans, have to remove the pan to get at it. ... 1997 Chevrolet K1500

O.k firsty thank you 4 your time ..its a 1989 bronco 11 2wd 2.9 L 5 speed manual trans. {with transfer case] .... o,k, when i started the engine with the clutch in , every thing was fine. i put it in 1 st. gear and let out the clutch. from the normal point of engagement, and with the clutch pedal totally out , a "rotating" squeal/scraping like noise,started, and the truck didnt move. the noise stopped when i pushed the clutch back in. shifted to 2nd then to 3rd, same thing no move-ment, just th


You are in trouble, expect a visit from the police soon. Actually the thing is over 20 years old and you need to do the clutch, replace all the parts and resurface the flywheel. Every part on the car will fail with age and use, most likely someone di ... Ford Bronco II

My oil is black and smells like gas. i want to change my oil because it scares me but i dont know what type of oil to use for my truck.it is a 1987 xlt ford ranger truck with a 2.9 l.engine from a 1988 ford ranger with a rebult tran. i need to put atleast 1 qt. of trans.fluid into evry 2 weeks. i have a water leek from the pressure plate behind the trans. im allways putting water in it. i had to pull the thurmastat out. and my engine is still overheating. truck idole is way off it go high and lo


A lot of stuff to fix here\015\012oil: with the truck running hot, I would use a heavy oil, like 10-40\015\012trans: where is the leak? If pan, tighten bolts. seals are much harder repair\015\012water leak: possibly a freeze pl ... 1987 Ford Ranger

My oil is black and smells like gas. i want to change my oil because it scares me but i dont know what type of oil to use for my truck.it is a 1987 xlt ford ranger truck with a 2.9 l.engine from a 1988 ford ranger with a rebult tran. i need to put atleast 1 qt. of trans.fluid into evry 2 weeks. i have a water leek from the pressure plate behind the trans. im allways putting water in it. i had to pull the thurmastat out. and my engine is still overheating. truck idole is way off it go high and lo


... 1987 Ford Ranger

2001 dodge dakota stalls when put in reverse on first start up of the day. If put in drive it runs and drives fine and also after truck is driven and warms up it will go in reverse just fine. transmission was recently rebuilt. i took it back to shop they could not find anything wrong with trans and said it sounds like an engine problem. There are no codes for engine or trans and the engine light is not on. any ideas


... 2001 Dodge Dakota

99 Dodge Ram 1500 5.9 I put a new fuel pump in my truck. i started the truck and it was running fine. after i put everything back together i started the truck and as long as i push on the gas and keep it ideling high it will continue to run. once i let off the gas it will just die. no puttering, just quits. Battery has to be jumped also to start it. once jumped it will start the truck on its own 2 times then has to be jumped again to start. Radio, lights will work.


I would charge the battery then test the alternator ,low voltage could be the problem ... 1999 Dodge Ram

How many gal of antifreeze should i put in the coolant system? I put 2 gal in as there was little left in the system. I went to drive the truck and within 15 min the truck was over heating. The antifreeze that came out of the reserve line froze to the frame. Did I not use enough antifreeze? Has had a coolant system change ie; new radiator, thermostat, water pump, hoses with in a couple of years. nothing appears to be leaking and all was fine until I put in the new antifreeze.


... 1989 Ford F 250

I have a 1994 chevy 1500 2WD truck that I leave it parked at a ranch for several weeks in between uses. When I put truck in drive after sitting for a few weeks, the rear left wheel will not turn. Right side wheel turns fine. I have to put it in reverse and lightly apply gas and then put it in drive again and it usually frees up. After getting it broke loose the last time and drove it for aboput a day, I got around to pulling off wheel and looked at brakes - no leaking brake cylinder, brake co


Hi,This problem won't be your diff, it will be the brakes, even though you don't apply the emergency brake now, the problem is with the foot brake.I would say that the brake shoes are not returning properly and when you stop to park the t ... 1994 Chevrolet C1500

Recent issue of 1996 formula trans am not starting or even turning over after the battery has been used for a short while. For example, will not even turn over after having radio on for a few minutes with engine turned of, or after using the lighter to power an air compressor for a few minutes with engine turned off. Sometimes clicking and lights going on and off, then nothing. Had battery tested and its fine, alternator is working just fine. Car will start after removing battery and putting it


It kinda sounds like the battery isn't getting power out to the cables. Corrosion may be the problem, If you can get a meter on it, see if you have good voltage at the battery, and to the cables, and that it's grounded good.Follow it away from the ba ... 1990 Pontiac Firebird

When starting my 2003 Olds Silhouette I have to let it crank for a while for it to start. This just started this past week after my son used it and put in some gas. I filled the tank after he had used it and I thought the gas cap was not on tight but I did not get the warning light on the dash, I had that several years ago. I don't know if the cap being loose can have an effect. Once I get it started it runs and sounds fine. If I restart it shortly after shutting it off it starts fine but i


This is a very common symptom when the fuel pump is about to fail. You need to get it diagnosed which most likely means leaving with a shop for a couple days so they can experience the problem and do testing ... 2003 Oldsmobile Silhouette

I have a 2003 ford focus 2.0 sohc. the trans has been replaced with a used trans. new trans shifts fine in drive but when put in 1st gear does not move. i replaced filter and cleaned shift solenoids. what might it be?


... 2003 Ford Focus

I'v changed the starter on my 2001 f150 super cab because it went bad and, accidently when i put the new starter I put it wrong, I put a positive with a negative together and when I tried to connect the batery the batery posts sparked of course, so I took the starter off and reconnected it the way it should. The truck started and seemed to be fine exept for a small electrical smoke smell . I let it warm up for a while and when I retried to start it would'nt turn on so I took the starter off and


Check your fuse links up near the battery and starter soleniod. When you crossed the wires there is a wire or fuse link with melted insulation and that is wher the oroblem should lie. Once you find and repair the wire you should be fine. ... Ford F-150

My 2000 Dodge Ram 1500 (318) truck was running fine but then my transmission went out. I replaced the transmission and now when I start my truck it has no power and backfires through the intake to the point its not driveable. I connected everything back as it was before I changed the trans. I did get a P0351 code and I changed the coil but made no difference. I have put on a new rotor & cap and new plugs. No change! Does the new transmision have to set to the truck somehow?


Did you remove the flywheel for some reason\015\012or damage the crank position sensor? ... 2000 Dodge Durango

Stays in first gear at high RPM's Will shift fine when I let off the gas and all other gears shift fine. Trans oil is clean and full. Traction Control off light is on and will only go off when car is in park. Stay off for about 5 minutes after car is put into drive. Cruise control has also stopped working. Everything worked fine a week ago, Checked all fuses and rebooted the ECM by disconnecting the battery. Check engine light on. Code says I need a new oxygen sensor.


... 2000 Pontiac Firebird

I have a 94 k1500 with a tbi 350 it idles fine but as soon as you put it in gear it dies i changed throttle position sensor and plugs wires rotor and cap still not better you let the truck sit a week


Check the idlle control valve ... 1994 Chevrolet K1500

My equinox is over heating when stoped at a light fans work fine, changed thermistat and still the same problem while using the air or not using the air I have to put the truck in park and keep the rpms at about 2300 until I get moving again is this a common problem with this engine?


Sounds like the fins in the water pump have disengauged from the shaft. raising the rpms will help. you really need to remove the water pump and see if it is in good shape, better off changing it if it is out. best of luck. ... 2005 Chevrolet Equinox

I have a 1997 toyota tacoma Sr5 with the V6. the orginal engine had a bad head gasket. so i found a used engine with supposedly 75000 miles on it. for only $550. the truck runs fine, starts fine and i have been driving it for a while now. but when i put my foot in it, it sounds like its drowning. it doesnt have any get up and go. just wondering what could be causing this? i cant even pass another vehicle because of it.


Could be loss of fuel or intake could be many things a spark plug or it just needs a tune up ... 1997 Toyota Tacoma

Fuel Pump I have a 1993 Nisssan PU 4cyl It has been setting for 3 almost 4 years not running. The truck was given to me to give to my son for his 16th b-day but when they put in a new battery it will only crank thye sprayed either into the carb and it will run only untill the either wears off could there be a lot of water in the tank from setting so long. or what might cause the fuel pump not to run. It ran just fine last time the truck was used.


Well dew, the worst thing for a car is to sit unused for a long time. After 3-4 years, the gas is bad, and you probably need to take the entire fuel system apart and clean it, or replace it. That would include from the carb/or injectors all the way ... 1993 Nissan Pickup

I have a 91 jeep laredo.. 6cyl in line auto trans.. sometimes it will not shift from 2nd to 3rd when it does no slippage at all ,trans was rebuilt not long ago , seems if i have the vehical outside in the cold it will work fine put it in warm shop and then take it out and problem starts.. last time it was working great, pulled into car wash washed engine and undercarrage and then problem starts again..it has all kinds of pwer but wont shift up past 2nd. when i let off on accellerator rpm drops f


Have you checked all trans linkage for proper adjustment? ... 1994 Jeep Grand Cherokee

1995 mercury cougar xr7. when my transmission is cold,and i accelerate hard,the trans. won't upshift until i let up on the petal. when the trans. is warm, the gears shift fine when i put the petal to the floor. the oil is clean and does not smell burn't. this question would be better answered by someone who has rebuilt transmissions.


I am assuming you have check the fluid level according to Mecury's instructions in your owner's manual or on the dip stick and it is not low. Your car is 15 years old, and I would suspect the filter is partially clogged. Change the transmission fluid ... Mercury Cougar

A/C -Heater Blower switch won't work even with switch ON? Our 2000 Grand Vitara's A/C - Heater Blower speed switch recently stopped working. The air would blow out fine when we "inherited" the car, but a couple months after using the air, the air would blow out intermittently. (Hit and miss) and (air flow was fine). If we pressed in or put pressure on the blower speed switch, the air would blow out. When we let go of the air speed switch, the air would cut off. Checked the f


... 2000 Suzuki Grand Vitara

While exilerating the trans shifts thru the gears fine but when you let up the gas it go into a free wheel and make a winning noise, if I put it into neutral and give it some gas and shift it back todrive it goes back into gear, until I let up the gas and it repeats the free wheel.


Replace the trans filter and fluid flush if that don't fix it the torque converter may be bad\015\012 first check the fluid level and for trans or trans line leaks ... Dodge Dakota

I have a 2002 suburban and it has a random click/cracking noise in the rear. I can hear it when I drive, and also when I put in park and release the brake. Sometimes when the truck mover forward those few inches on a incline during the park and brake release process. The truck runs fine no slipping on the trans or grinding


I would start with having someone under the vehicle while someone inside the truck stands on the brake and shift from reverse to drive several times and verifies that the u joints are not "bouncing" . you will notice this by where the two sections ar ... 2002 Chevrolet Suburban

I have a 1991 ford f-150 xlt.I put a used battery in truck and let it charge up.It ran aprx 30mins and it ran out of gas. Put gas in it and tried to start it and now it will not start.Both fuel pumps are working.What could be the problem?


If you have dual tanks, like I have, the there is a mechanical fuel selector valve that both tanks hook to. When it fails, it usually fails so you can't get fuel out of the front tank. If you haven't tried yet, put some fuel in the back tank and give ... 1991 Ford F150

Alternator f-150 ford f-150 alt reads 12.6 from alt case to pos side of batt. alt guage on dash shows good charge but batt diagram shows red all the time on dash. have changed two alt ,but same results----batt goes down so truck will not run. put portable jumper on and truck runs fine until used up.


Replace the link between the alternator and the positive side of the battery. This is a fusable link and sometimes can cause this problem this would be the easy fix and is hard to test ... 2002 Ford F150 Regular Cab
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 2.9916 seconds