Having problems with your 1997 Chevrolet Blazer ?

97 s10 blazer cuts out and loses power while driving.

\015 Fuel pump has been replaced so i'm wanting to know if it could be the crankshaft sensor.i changed the spark plugs,wires, cap & rotor, the ignition switch, fuel pump, fuel filter on my 6cyl 4x4 1997 blazer and i am having a problem starting it. and when it starts it backfires when you stomp on the gas. gradually it runs fine. it has no pick up at all. it's an EDI system so i know firing order isn't the problem. What can it be already?\015 Posted / edited by AnonymousUser on : 11-12-2017

Answers :

Have you checked to see if it is throwing any codes? You can bring it to any autozone and they can check the engine codes. It could be crankshaft sensor could be TPS sensor, or a couple other sensors. Having the engine codes being thrown should narrow it down. Once you get that let me know and I can assist you further.
Thank you,
Lee
Repair Help & Product Troubleshooting for 1997 Chevrolet Blazer

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0058 seconds