Having problems with your 1996 Ford Explorer ?

1996 ford explorer

\015 Disconnected the battery and sucessfully got the overdrive indicator light to turn off, however the tranny seems tobe slipping when I shift into drive even after topping off all the fluid levels. Now where do I go from here?\015 Posted / edited by AnonymousUser on : 23-10-2017

Answers :

Actually,when the O/D light is flashing,the vehicle is indicating a problem within that specific system.When this happens with any system on the vehicle,a diagnostic trouble code is set in the vehicle computer's memory.What you did by disconnecting the battery was simply to erase the trouble code from the computer's memory.If the transmission feels like it is slipping,it probably is,and that's where the problem will be.You can drive the vehicle,and the code will reset again sooner or later,as will the O/D light flashing.Have the vehicle scanned when the code resets,try not to drive it very hard,because if the trans is slipping,driving it will worsen the damage/cost to repair.
Repair Help & Product Troubleshooting for 1996 Ford Explorer

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0117 seconds