Having problems with your 1995 Jeep Grand Cherokee ?

2005 GRAND CHEROKEE IDLES ROUGH, HESITATION AT TIMES ON ACCELERATION FROM STOP. GAS MILEAGE 4-5 MILES LESS. CHANGED SEVERAL SENSORS , CHECKED COMPRESSION, NEW PLUGS. ?????????

Posted / edited by AnonymousUser on : 22-01-2018

Answers :

Repair Help & Product Troubleshooting for 1995 Jeep Grand Cherokee

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

2005 GRAND CHEROKEE IDLES ROUGH, HESITATION AT TIMES ON ACCELERATION FROM STOP. GAS MILEAGE 4-5 MILES LESS. CHANGED SEVERAL SENSORS , CHECKED COMPRESSION, NEW PLUGS. ?????????


... 1995 Jeep Grand Cherokee

1993 cougar, v6, about 2,000 miles. Engine is misfiring on cylinder 6. Code scanner does not reveal any codes or anything other than the misfire.I have changed the spark plug and wire with new ones. I have done a compression check, the whole bank checks out fine. Also have checked engine vacuum, its steady at 19. The distributor is brand new and timing is about 7 degrees BTDC. Mass air, IAC, throttle position sensor, coil, Ignition control module and EGR are all brand new. I can hear what seems


Spray carb.and choke cleaner back there and see if it makes a differance ... 1993 Mercury Cougar

1993 cougar, v6, about 2,000 miles. Engine is misfiring on cylinder 6. Code scanner does not reveal any codes or anything other than the misfire.I have changed the spark plug and wire with new ones. I have done a compression check, the whole bank checks out fine. Also have checked engine vacuum, its steady at 19. The distributor is brand new and timing is about 7 degrees BTDC. Mass air, IAC, throttle position sensor, coil, Ignition control module and EGR are all brand new. I can hear what seems


Replace the coil ... 1993 Mercury Cougar

No power, 99 Tacoma Truck, 4X4, TRD, Extened cab, V6, automatic tran. No more get-up and go - Loss power: gutless truck. approximately 86,000 miles. It has been acting this way for quite some time now. I changed spark plugs several times, sprak plug wires, cleaned mass air flow sensor, new air filter several times. There is no check engine light on. Also, transmission takes long time before shifting into 3rd/drive when cold. Thank you,


My truck did the same thing. I changed the plugs with the ones the parts store recommended and it still acted gutless. Then I took it to the toyota dealership and they told me the plugs were not the right ones. So make sure you have the right plugs w ... 1999 Toyota Tacoma PreRunner

My geo will not rev up , i have , changed fuel pump, cleaned all and replaced all filters, changed fuel injector, check timing, change map sensor, check throttle postion sensor, changed water pump, changed gas tank, new spark plug, checked compression 140 psi, new air cleaner , not sure about O2 sensor, I have prayed for it and cussed at it HELLP!!!


... 1989 Geo Metro

Misfires 2002 Honda Accord I have misfire on 2,3 and 5 I have tried so far New plugs,flushed and changed antifreeze,new thermastat,cleane EGR and cleaned out all the ports and intake passage ways,replaced the injectorsand checked for fire,changed the throttle bady and sensorscleanedIACV,checked the compression,checked wires to ECV,replaced the Cam sensor and crank sensor,checked the battery and alternator. Please help


I assume your fuel pressure was also checked? ... 2002 Honda Accord

I have a 1999 Buick Century with 168,xxx miles on it. I used to get 25-28 miles to the gallon but in the last year its gone down to about 21 mpg. The check engine light was on and when checked it was the massive air flow sensors. I replaced that this month but my MPG hasn't improved. I have new tires that were put on in December as well as an alignment. March of last year I changed the fuel filter, spark plugs, and wires. In July I put in a new fuel pressure regulator. Any ideas on what might be


... 1999 Buick Century

I have a 2001 dodge stratus r//t 3.0l. Will not start. I checked timing, replaced map And tps sensor,distribitor cap and rotor button, checked fuil system, changed gas just to be safe. No more codes after replacing sensors. Gets good fire on new plugs. Gets gas... Checked compression, good.wont even start on starting fluid


If its got compression, fuel and spark at the right moment and still doesn't start call ghostbusters. how did you check timing, manually at the cap or with a light? I've never seen a stratus with a 3.0, how did they fit that one in there. ... Cars & Trucks

2003 hyundai elantra auto trans. 150,000 plus miles new tranny fluid input and out put sensor, shows now p1529. when taking off with cold engine hear a loud bang out of front and check engine comes on have changed plugs and wires recently. tranny fluid is correct stuff. only other thing radiator clamp broke and antifreeze all over top of tranny fixed and cleaned checked connectors ok have a new innovia code reader can this pick up tranny codes besides p1529


On top of the tranny, by the selector lever, there is the range switch.\015\012Disconnect, clean therminals, add some dielectric gears to the\015\012terminals, and reconnect. Disconnect negative battery terminal for 30+\015\012sec., reconnect termina ... 2004 Hyundai Elantra

Check engine light on steady, car runs fine, gives code 300, random misfire, Sometimes on cold start, runs very rough, sometimes for several miles, check engine light blinks, gives cat. conv. code. I have changed the cat. I have changed the plugs, wires, coil, O2 sensors.


... 2000 Mazda MX-5 Miata

97 LicolnLincoln Continental P0131Continental P0131 and P1131 02 sensor codes. Car has a 4.6L V8 with 79K. Conti idles and runs great even with this error, but since I got these codes the gas mileage has dropped from mid 20’s to 10MPG. The car seems to run hot as the radiator fans kick on every couple minutes. I replaced bank 1 sensor 1 heated O2 sensor, new air filter, plugs, wires, PCV valve, oil, oil change, and cleaned MAF sensor. I also checked for vacuum leaks with nothing found. Al


If Im not mistaken that code is due to a lean mixture which in turn can cause an engine to run hotter.Have you had the line pressure checked for the injectors. If you have pulled all the spark plugs are there some with colors different to others? Try ... 2005 Ford Lincoln Continental

Wondering what else we need to try: Our truck runs very rough-cuts out and cannot go very fast (maybe 25- tops). We have had a few different people work on it and they have put on new parts. We have put on a new pick-up assembly, new spark plugs & wires (whole tune-up kit), replaced gas lines, changed oil, and most recently replaced coil and wiring to the coil. They also checked the timing, and compression, and adjusted dist. pickup syn. sensor. We have also tried "Heet" in the gas tank. A


Check the catalytic converter on the exhaust. They are bad about getting clogged up on a dodge. If they clog it will make your engine run poorly and have no power due to little or no exhaust flow. Its a pretty common problem. ... 1993 Dodge Dakota

Severe misfiring My 1999 Miata with barely 25,000 miles started acting up a year ago with the check engine lite on/off constantly. Garage checked code - random misfire on cold start. I have now replaced the oxygen sensor, front catalytic converter, had a complete tune up and oil change, all new ignition wiring and the problem is WORSE. Mechanic went all over everything again to see if anything was lose, etc. - nothing. Over $1,000 later I have a growing serious problem. I do not know where to tu


One thing you can try is starting it when cold and while it is skipping..shut it off and remove the spark plugs and see if they are wet with antifreeze,i have seen this on a few vehicles and is a hard problem to catch,if there is antifreeze on the pl ... 1999 Mazda MX-5 Miata

I have a 99 monte carlo with a 3.1, the check engine light came after I had changed the wires and plugs about a month ago, the code came back as p0401 egr insufficient air flow,I bought a new egr, gaskets, I had erased the code several times,only to have the light came back on after 40 miles, I just can't figure out what else could be wrong, The car has 150,000 miles on it. Thanks and have a great day Mark Z


Remove the air tube to the throttle body. Open the throttle all the way and look inside with a flash light. You are looking for a lump of carbon at the egr port int the intake manifold. Remove the egr valve, using a hanger or stiff wire, ... 1999 Chevrolet Monte Carlo

I have a cold start problem with our 99 Honda EX CRV. 185K Miles. Car eventually starts after several tries. Once it does start cold... there are no further starting problems the rest of the day... until the car sits overnight and becomes cold again. Checked the alternator, battery (Die Hard-only 3 years old)... both good-clean connections! Changed out temp. coolant sensor and Ignition Switch. Changed out spark plugs, rotor, distributor cap @15 months ago. All fine! I do hear an occasional brief


... 2009 Honda CR-V

Replaced bad fuel pump, installed new relay and fuel filter, engine turns over but is not firing on..... positive the fuel pump is pumping gas and checked to see if gas was going thru fuel filter. Tried small amount of gas and start fluid to engine to start. It still wont "fire" on. Not sure what to check next? changed distributor cap and spark plugs less than ten thousand miles ago?


Hi, Ok you have confirmed that it's not a fuel problem. You need to check for spark. Pull the coil wire off of the coil(secondary lead-looks like a spark plug wire) Have some one crank it over and listen for a popping sound. IF yes, spark is at the c ... 2002 Chevrolet Blazer

Transmission fluid i was changing the oil on my wifes car and took out the wrong plug draining about 1-2 quarts of transmission fluid before i could get the plug back in. i cant figure out where i would add transmission fluid nor is there a dipstick to check the level of fluid. is it ok to drive to the dealership? will driving the car with less transmission fluid damage it? where do i add fluid at? new car with only 5,500 miles.


... 2009 Kia Borrego

Acts like its running on 2 cylinders,cutting out,i did:new fuel pump,fuelfilter,coil pack,plugs,fuel pressure check,compression check{ok},tps snsor,map sensor,still no change,still cutting out


How are the plug wires and air filter ... 1990 Pontiac Grand Am

1999 GMC Jimmy 2 Wheel Drive had check engine light to come on, diagnostic code shown was 402 for a low emissions problem with the catalytic converter, catalytic converter was checked and there was no problem, is it possible an O2 sensor needs to be replaced? low mileage vehicle of 84,000 miles with regular maintenance, good condition, tune up recently done with new spark plugs, wires, distributor & cap, fuel filter, also the original converter was replaced 1 yr ago for a rattling sound. As far


Replace the O2 sensor and ensure the codes are cleared from the OBDII. This shoudl correct the problem. ... 1999 GMC Jimmy

I have a 1995 Buick Park Avenue that has been sluggish and getting poor gas mileage for quite some time now. I have been told several times to replace the mass air flow sensor. I have recently had it in the shop for another problem and it just so happens that this is one of those cars that you can't put a diagnostic computer on it to check. It' a half and half car. They were changing over from the old computer to the new computers. However these mechanics did a fuel check and found that it h


Yeshowever, I would also just engine compressionif compression is low (weak engine) then there is less vacuum for things like the fuel pressure regulator ... 1995 Buick Park Avenue

My 2003 altima 2.5sl has the check engine light on....... after new plugs and the front o2 sensor changed it is now reading the cat !!!!!!!! now im also using oil at 1000 miles between oil changes ????????? what do i do ?????? thanks JIM MORGAN


NEED TO RESET TUNE UP SISTEM ... 2003 Nissan Altima

Got some gas at Kroger,engin off;; had driven less than 5 miles made one stop,engin off;; a mile later loss power,check engin lite on, it started after a minute;; two miles on did it again;; got to store and turned off (30 minutes stop) started working like new no check engin lite since just had oil chng and fluids check and fill.  plugs and wires 1 year new (not cheap either platnum deals) plugs checked ok what gives. i started it this AM no check engin lite. drove around block,,,,like new


I have been buying kroger's gas for like 2 years. Had no problem till last week. Apparently we have been using their regular which is E85 15%gas and 85% ethananal. Took it to the dealership and was told it was bad gas. they said it didnt even look li ... 1995 Chrysler Concorde

I HAVE A P0300 OBD CODE I DID A COMPRESSION TEST TO ENGINE AND IT PASS THE TEST,I DID CHECK EGR VALVE,CHANGE SPARK PLUGS,IGNITION WIRES, CAP AND ROTOR, I DID CHECK TPS SENSOR MAF SENSOR,FUEL PRESSURE,AND OXIGEN SENSORSI I FOUND THAT ON BANK 1 BOTH SENSORS (UP STREAM & DOWN STREAM )WORKS NORMALY BUT ON BANK 2 THE SENSOR 1 CHANGE FROM 0 TO 600 MILIVOLTS BUT NO CHANGES FROM RICH TO LEAN &SENSOR 2 HAS 0 MILIVOLTS & NO CHANGES FROM RICH TO LEAN SO I SWICHT SENSOR TO TEST THEM FROM BANK 2 TO BANK 1 AN


... 1997 Nissan Pathfinder

I have a Grand Am, manual trans. quad 4, with 137,000. Having a problem with bucking sometimes on take-off or driving and try to accelator and it bucks. Have done the following things..new air filter,plugs,fuel filter,new spark tower and new boots, new oxygen sensor. fuel injection cleaner..NOT SHOWING check engiene light..have had diag. check showing no other sensors. Could it be a crank shift sensor, should it show up on diag check? Car will run fine for a few miles, seem like longer you drive


DON'T KNOW THAT THE CAUSE IS BUT 900 RPM IS WAY TOO HIGH FOR A NORMAL IDLE SPEED.\015\012WHILE IT IDLING HOSE THE ENGINE WITH A MIST OF WATER AND LISTEN FOR A CHANGE IN IDLE SPEED OR AN ELECTRICAL SHORTING SOUND.\015\012SHORTING SOUND = P ... 1996 Pontiac Grand Am

I have a 2002 TrailBlazer with the straight 6,diognostic check said #3 cylinder was dead or misfiring, also map sensor showed up. #3 cylinder was misfiring, so to test the coil pack I swapped #3 coil pack with #2 cylinders coil pack, no change and a 2nd Diaognastic now said #2 cylinder was misfiring, Ok need new coil right ? so bought new coil pack and spark plug and changed out and no change, so bought new M.A.P sensor, again no change, still runs rough and missing, what could it be ?


Did you replace only one spark plug? that can cause issues because of differences in resistances between cylinders. also, did the map code stay off after replacing? ... 2002 Chevrolet TrailBlazer
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 4.8990 seconds