Having problems with your 1995 Chevrolet Monte Carlo ?

I changed all three coils and plugs and wires. I also verified the correct firing order as well as the plkug placement. the engine will turn over and hit but will not idle or accept throttle ,after several attemts of trying to start, all the plugs carbon up badley. can anyone help me figure out if it is an o2 sensor or what?

Posted / edited by AnonymousUser on : 20-02-2017

Answers :

You changed coils, plugs n wires, but did you check if you have spark? your ignition module could be faulty. Don't forget to clean or replace plugs before trying something else and while you'r at it check your firing order one more time.
\015\012
\015\012Also check for:
\015\012
\015\012Vacuum leaks, uneven or low cilinder compression, ignition timing, dirty air filter, spark plug gap, idle air control selenoid sticking, EGR valve stuck open and faulty map sensor.
\015\012
\015\012I am curious on how all this started!! When was the last time the car ran fine?
\015\012
\015\012Good Luck buddy!!
Repair Help & Product Troubleshooting for 1995 Chevrolet Monte Carlo

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0238 seconds