Having problems with your 1994 Chevrolet S-10 ?

1994 chevy s-10 blazer. will start. runs for 25 or 30 minutes and dies when you try to accelerate or after it warms up. will not re start until it sets for 30 minutes. replaced distributor cap, fuel pump, fuel pump relay, entire distributor, computer in behind the glove box, coolant control sensor, throttle position sensor. no change. has plenty of fuel pressure and has spark. the wires to the spider assembly check ok when unplugged and checked during no start episodes. I am pulling my hair out

Posted / edited by AnonymousUser on : 20-11-2017

Answers :

This sound like an EGR valve that has gunk in the needle seat. Take the valve off and clean it thoroughly of if it is too bad replace it.
\015\012
\015\012You can prove it is an EGR problem with a vacuum gage connected via a tee to a direct manifold sourced vacuum hose. A sudden drop in vacuum usually is caused by the EGR valve not seating.
\015\012
\015\012Try this before you remove it for cleaning. The next time it does one of it's dead for 30 minutes episodes raise the hood and give the EGR valve a good whack with a screwdriver or hammer HANDLE. Then try to start it again. If it starts right up you know you need to FIX the EGR problem.
\015\012
\015\012 Thanks for using FixYa.
\015\012 Kelly
Take it to a muffler shop have them check the catalytic converter it may be clogged
Repair Help & Product Troubleshooting for 1994 Chevrolet S-10

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0062 seconds