Having problems with your 1994 Chevrolet Corsica ?

How to replace coil packs on 1991 Corsica 3.1 L engine?

\015 How do I reach the coil packs on 1991 Chev Corsica to change them? Remove the radiator? Lift the engine?\015 Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Repair Help & Product Troubleshooting for 1994 Chevrolet Corsica

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

How to replace coil packs on 1991 Corsica 3.1 L engine?


... 1994 Chevrolet Corsica

I have a 2005 cavalier. Just replaced the enging with a chevy malibu classic engine, came with a different fuel rail, so replaced the gas lines to match the fuel rail, replaced coil pack, coil pack module, spark plugs, spark plug wires. Showing random misfire. Anyone knoe what this problem could be? Does the computer need reset since it was a mailbu engine? Thanks for any help!


Is it misfiring ? if not reset see if comes back ... 2004 Chevrolet Cavalier

I have a 1996 ford ranger 2wd 2.3 engine. when i had the code read it came up with p301 #1 cyl misfire. I was told to replace the coil pack, Which coil pack should i replace? the one clostest to the front of the vehicle or the one that is located towards the rear of the vehicle. My truck has a bad mis and it is using lots of gas. Will replacing this coil pack correct my mis and my gas consumption problem? Please help I'm stumped.


I would replace all of the coil packs. if one goes bad, then the others usually follow. if you don't want to, i would say the one closest to the front. but you can always try different ones by taking it back off and putting it where the other neighbo ... 1996 Ford Ranger SuperCab

I have a 96 chrysler town and country 3.8. engine will crank, wont fire. about a year ago I replaced the feul pump and filter, I know its getting gas. replaced the coil pack and the crank shaft possition sensor. getting the 5 volt marker voltage on the plug for the coil pack but nothing else on the other 3. turn the key on and the check engine light does come on. checked for codes on the OD. gave me code 999. cant find a record of code 999. located the ASD Relay under the hood and swapped


... Chrysler Town and Country

Replaced alternator, Again, on 1998 Ford Contour SVT, 2.5L 6 cyl. Alternator working fine but engine running very rough, not good power, etc. Checked power to coil pack, 12.5 volts, no power to plugs or wires. Car won't start. Cranks good. Replaced Coil pack, it was cracked in several places and thought it might be the problem. No start. Checked power at coil connector plug only one post of 4 has power when unplugged. All have power when plugged in. Is this correct or bad plug? Any ideas on no s


First off,I hope you are using a digital,not analog meter,the analog meter can blow the computer.Check all fuses,and then the crank shaft sensor maybe the problem,they are bad to go out on these models.It is mounted most likely on the transmission,le ... Ford Contour

Cylinder #2 Misfire- Engine Code P0302. We replaced out #2 coil pack, replaced out all the spark plugs, replaced the cam sensor. Start rough on and off, sporadically. Always runs fine though after I w


Duplicate question ... 1997 Honda Civic

I have replaced the coil pack on my 2002 ford taurus with the 3.0 24 valve engine. I have no spark to cyliders 3 and 4. I have also replaced the electical connector to the coil pack as well. All 4 wires have power and the yellow and white and the yellow and black pulse with the test light, the yellow and red and the solid red wire have a steady light with no pulse. Do you have any suggestions please. I have also checked all grounds and they seem to be fine. Do also take into consideration that t


... 2002 Ford Taurus

2003 Northstar 4.6 L V8 VIN #Y. Engine runs rough. No problem with acceleration though. Replaced spark plugs and coil boots to no avail. Warning engine light still lights. OBDII says lean on banks 1 & 2. My mechanic syad I neede to replace the coil packs but, I don't see how that would help. Any suggestions?


... 2003 Cadillac Deville

I have just repLACED THE COIL AND MODULE PACK WITH A KNOWN good used one the vehicle now runs but the check engine light is now on. I have a code reader and it says that the crank sensor is the problem. If it was the problem than i dont think the engine would start. Could the coil & module pack be it.


Dont trust a code reader on this car it will not work correctly ,and not at all on a europeon market vehicle ,you havent stated what model vehicle but a some of these vehicle will throw the engine light if the vacumn pipe is left off or its deteriora ... Volkswagen Jetta

Engine Light problems , I have replace Fuel injector, new Coil pack new pig tail lead for #i1 Coil Pack , Check Vacuum, and Compression Cylinder, Now if the Idle fall to 535 RPMs Engine light will come on and a Code of P0301 Mis fire on Cylinder 1 is this ldle to Low if the light comes on I can Slowly push the gas and 625 to 700 Rpms the light will go Off


You've done all the right things, so piston rings or leaky valve is out of the mix now. Now back to the simple stuff. Change your spark plugs to A/C Delco 41-103 if you haven't already. Don't try and gap them, the iridium will come off and possilb ... 2006 Chevrolet Trailblazer

Have 1995 jeep wrangler-2.5 engine, won't start, have power to coil pack but not past coil pack, replaced coil pack with new one,electrical problem or possible sensor just not sure what to look for,anyone have any idea's? thank's!!!


Most common cause is the crank sensor...It tells the computer when to fire off coil. Cam sensor does this as well but is less prone to failure. Don't change parts because I said so! Proper testing is essential! Test b&c terminals of sensor with ... 1995 Jeep Wrangler

2007 kia Rio Engine shuts off intermittently. History: 1 year ago we had an issue with rough engine and power issues (Approx 150k). replaced spark plugs and same issue. Engine light codes reported misfire on cylinder 3&4. replaced both coil packs for those cylinders and no problems since. Then out of the blue a couple of months ago the engine would just shut off randomly, no bogging or rough idle, just the engine would stop running. this would happen usually when slowing to a stop, making a slow


The\012engine and the automatic transmission in this vehicle are computer\012controlled and in most cases when a fault occurs a fault code is\012stored in the memory of the computer control module. There are\012exception to this, such as the Ma ... 2007 Kia Rio5

Sat, sometime in January cel appeared Sun Engine steaming, upper hose clamp on engin was loose at engine connection cyl 1,3 side tightened clamp, washed away antifreze Mon read codes, engine misfire cyl 1,3 assumed something to do with antifreeze leak, cleared codes. 60 miles cel, same codes, replaced sparkplugs, swapped cyl 1,2 wires, cleared codes. 60 miles cel, replaced coil pack, air filter, ysed can of injector cleaner, cleared codes, 160 miles cel, used another can of injector cleaner. 160


I am sorry to tell you this but sure sounds like a head gasket getting weak. By year a model I am figuring you have a EJ-25 2.5 boxer motor. Not easy to really do plug test but are your plugs coming out with moisture on them? Check oil for water also ... 1998 Subaru Forester

Cylinder #2 Misfire- Engine Code P0302. We replaced out #2 coil pack, replaced out all the spark plugs, replaced the cam sensor. Starts rough on and off, sporadically. Always runs fine though after I wait a minute or 2 to warm up.Engine light still come on. Engine light goes off once and while too after it has came on. Always the same code. What do we do now? 2002 Honda Civic EX. 160k+ miles. Installed brand new alternator 2 years ago.


Please read the misfire diagnosis and repair information at this website. ... 2002 Honda Civic

Hard to start, when it does start it spits andThis is a 1997 Camaro RS 3.8 engine. hard to start, when it does start it spits and spatters, then dies.doesn't want to restart at all .After several attempts it will only act like it may fire. Replaced spark plugs and wires. Replaced fuel pump, and coil pack. Still didn't help it. No service engine MoreThis is a 1997 Camaro RS 3.8 engine. hard to start, when it does start it spits and spatters, then dies.doesn't want to restart at all .After several


You have a bad ignition module. it is what the coil packs mount to. very common for this car. good luck ... Chevrolet Camaro

I have a 2000 vw new beetle that has an eletrical miss specially when i start the car after being cold.the spark plugs and the spark plugs wires were replaced but the miss is still present.one of the coils in the coil pack is a little bit weecker then the rest.the question is why when the engine is cold the miss is worse and the check engine light keep flashing untill the car is warm than the check engine light would stay on.and what is the solution. thank you


Check the resistances of the coils, check both hot and cold, If you have a greater variaton on one of the coils then the other change that coil. The reasoning does not always have to make sense. Logically the coil would be weaker the warmer the engin ... Volkswagen New Beetle

CRAP.............. I have a 2002 Saturn Vue 2.2L. I thought I needed to replace the timing chain, but when we took everything apart, the timing chain tensior, timing chain, and head, plus all the gaskets had to be replaced. We also replaced the spark plugs. We then went out and purchased coil pack modular. When we take the part that the spark plugs plug into out of the engine, and have it upside down, we have spark, when its in the engine the way it supposed to be, we dont have spark. We can not


Did you check to see if you have fuel pressure to your fuel injectors??? You probably have spark, just no fuel from your fuel injectors. Check that and go through the trouble shotting your fuel system, common for the fuel pump on saturns to wear out ... Cars & Trucks

2005 Pontiac Sunfire. No start condition this morning, finally needed a jump. Got it started but it was running real rough and had a flashing check engine light. Pulled the coil pack rail, checked connections. Replaced very old plugs (OE) and replaced. Still running rough AND Backfiring, but now the Check Engine light is solid, not flashing. The car is not driveable. There were NO previous check engine conditions on the car. It was running beautiful and quiet. Now it rattles and the rear pipe al


Timing is off, did you replace the wires as well? Check the timing? ... 2005 Pontiac Sunfire

A 1997 buick lesabre code 303 got my check engine ligfht on got a tune up an replaced coil pack after 25 miles my check engine light came back on still reading 303 what can i do to take care of this


... 1997 Buick LeSabre

Ford mustang - year 2000 - 3.8 liter The car is running but low power. It feels like it's down a cylinder. It is not running smooth. The ''check engine soon'' light is flashing.I've been told it's the coil pack by a mechanic that won't work it until Monday....today is Sunday. Is the coil pack is out? How hard is it to replace? It looks easy to get to. Any Advice?


BESURE TO NUMBER LOCATION OF PLUGS WIRES GOING TO COIL PACK.SO YOU WONT GET CONFUSED.REMOVE THE ELECTRICAL WIRES GOING TO COIL PACK.THEN REMOVE COIL PACK SCREWS.THEN REMOVE COIL PACK.I HOPE THIS HELPS. ... 2000 Ford Mustang

I have a 1998 Chevrolet Malibu with a 3.1 engine. The control module checked out to be bad and was replaced. The 3X & 24X Crank position sensors were replaced. All three coil packs were exchanged for good ones. I have 45 PSI at the fuel rail. I have sprayed starting fluid into the intake. I have spark across the sparkplugs. It is an orange to weak red in color. However I feel it should be enough to start the engine. The motor will turn over but the car will not start. Please advise....Lou


Hi, I was chatting with you the other day but the chat stopped responding. Glad to see you are now getting sparks, but weak sparks may not be enough. Not sure if you got to read the last stuff I was hoping to tell you in the chat, but I thought you ... Chevrolet Malibu

I have engine vibration in 2004 Trailblazer. Vibrates when at a stop. Some vibration when in nutrel, but really bad when put into drive. Had motor mounts replaced. Replaced the plugs and coil packs. Also had decarbonizing liquid and injectr cleaning fluid run through engine. There is a kinda of shudder when you turn motor off.


Good call on the engine mounts, this problem has had a lot of TB owners scratching their head. Hope you used genuine GM mounts, aftermarket mounts tend to crush too much sending you back with the same problem you started with. With aftermarket mount ... 2004 Chevrolet TrailBlazer

I am having the same issue as talked about above, but with a 1998 ford escort zx2. i have replaced the spark plugs and the wires and getting misfires on all cylinders. Then also just replaced the coil pack and car us running smoother, but the engine light still coming on with all 4 cylinders still misfiring. Wondering if there could be anything else that might be causing the computer to say the engine is misfiring, thanks.


When is the last time the car has had a timing belt could it be bad?? ... 2001 Ford Escort ZX2

I need to know which coil pack is coil pack D on a 2001 f150 with a 5.4 engine. the problem i am having is when i try to start the truck it just winds over and then slowly fires off i had all the injectors replaced by a local shop and it still does it any suggestions


D is the # 4 cylinder on the right bank ... 2001 Ford F150 Styleside SuperCrew

1996 dodge avenger. 2.0 engine. While driving the car stalled. After I got it home I started checking, and it had dropped 2 cylinders as far as ignition. Both coil packs are good. Someone had suggested replacing the cam sensor. No good. From what I can find, the crankshaft sensor could be a culprit in NO Spark but not dropping one coil pack. Is this true? I am tending toward a bad ecm/dcm computer. Steve


1. Yes, it's true that the crankshaft sensor could be a culprit in NO spark, but not dropping one coil pack. \015\0122. Of course, could be a bad Engine Control Module (ECM). If you can find another one in good condition, test the eng ... Dodge Avenger
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 3.1189 seconds