Having problems with your 1993 Saturn SL2 ?

2000 Saturn SL series 1.9 Starts fine has rough idle. new plugs and wires. question is: is it TPS?

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Keep it simple.
\015\012
\015\012Check for vacuum leak at inlet manifold......at idle simply spray some crc lube or similar (Brakleen is very good) around manifold and listen for increase in reves. If so leaking manifold gasket or similar.
Repair Help & Product Troubleshooting for 1993 Saturn SL2

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

2000 Saturn SL series 1.9 Starts fine has rough idle. new plugs and wires. question is: is it TPS?


Keep it simple.\015\012\015\012Check for vacuum leak at inlet manifold......at idle simply spray some crc lube or similar (Brakleen is very good) around manifold and listen for increase in reves. If so leaking manifold gasket or similar. ... 1993 Saturn SL2

Saturn sl2 rough idle wont accelerate. We replaced the timing chain, spark plugs, air filter, TPS sensor, and changed oil. We check the coils, plug wires, fuse block, and negative ground. Problems started leaving work. started fine, went to accelerate from the parking spot and it killed. Wouldn't idle or start. We made the above repairs and now it will idle but wont accelerate.


... 1999 Saturn SL

What would be some symptoms of a plugged or par tially plugged cat converter? i have a rough idle and hard to cold start also a puff puff(mis-fire )sound out the tail pipe...i have changed the plugs(properly gaped ngk's)new plug wires,new pcv,cleaned all grounds and battery terminals,removed egr valve and cleaned(operating properly)new ect sensor and harness(from saturn)what could it be,PLEASE HELP...THANKS in advance.it has a automatic trans.


You may have a timing issue which comes from the Engine Control Module. Here is some other info on the Cat converter:Catalytic \015\012 converters are defective when they become clogged or poisoned. You \015\012 may ... Saturn SL2

99 tacoma has hard time starting, runs rough idle till warm. Have replaced, fuel filter,spark plugs and wires, new IAC motor, cleaned out throttle body. smells of gas while starting, as if it's flooded. has new tps sensor, and engine coo;ant temp sensor also. gets a code reading for misfire on 1, and 3 cyl. replaced both ign coils. looking for answers.


... Cars & Trucks

I have a 1996 pontiac sunfire with the 2.2 litre 4 cyl , my question is, it has a rough idle but driving down the road its fine and only idles rough when engine is warm. It threw a p0300 random cylinder misfire so i changed plugs and wires,new o2, coils are good. Mechanice diagnosed it and said all it can be now is timing chain jumped a tooth and wants 700 to fix, does all that sound right? Could it be something else? I DO hear a slight clanking noise under hood when i start it but thats all. Pl


... Cars & Trucks

Hello, The GMC 89 TBI 305 in my truck eats up fuel badly in very cold starts. It will start then idle down to almost a stall then idles slowly back up, but remains rough until I step up the RPM's until the rough running goes away usually in 5 seconds or so. Then the idle will stay properly and idle down slowly in usually 5 minutes. Why do I have this rough start? The motor has a new fuel filter, plugs, wires, distributer cap, rotor, timing set and the garage bumped up the 5.7 amps to 6.0 amps t


Two thing ive found on this model is idle air control motor and the injectors like to foul out. using a timing lite to look at the injectors helps to aid to see if there spraying correctly. if this shows to be good the pressure regulator may have gar ... 1989 GMC Sierra

I have a 2001 Ford Escort. It was idling rough and starting to cut out when sitting at stop lights. I changed the plugs and within a week the Check Engine light came on. It is still idling rough but not cutting out. It runs fine on the highway, no hesitation. I had it checked and they said the cylinder 3 is misfiring. I have had the injection system cleaned, put on a new PCV sensor and put new plugs and wires on. Also I put a new fuel filter in. What else can this be? I would appreciate any help


Well the misfire in Cylinder 3 will commonly be that your plug has gone bad. If that is the only code that it is throwing out then it could be an array of things going on. It sounds though that you may have a throttle position sensor out or that you ... 2003 Hyundai Tiburon

I have a 1995 dodge caravan with similar problems. It has trouble starting and you have to rev it just right when you turn the key to get it started. After a while it will die and not want to start back up. The fuel pump is new and it works. It has a new tps idle control motor plugs wires rotor cap and distributor hall effect sensor. The ignition coil's resistance is in spec and the altinator tested good at autozone. All the wires seem to be good. Had a trouble code for tps voltage and asr relay


... 1995 Dodge Caravan

Villager rough idle, idle speed correct 750rpm+-, but rough (270k miles). New catalytic converters, oxygen sensors and cleaned the ERG valve and intake port to EGR valve in July for emissions testing (passed). Idling problem started right after that. Ran injector cleaner though the gas. Replaced most vacuum lines, PCV valve, fuel filter new 2009. Tuned up engine within last 3 months (plugs, wires, cap, rotor and timing). Cleaned the IAP valve but no significant deposition (not like the EGR


Http://groups.yahoo.com/group/villagerquest/\012\012clean MAF sensor heated wires with spray carb cleaner first ... 1995 Mercury Villager

ROUGH IDLE WE JUST PUT NEW PLUGS AND WIRES ON, BUT CAR IDLES ROUGH WHEN STOPPED. JUST STARTED ABOUT TWO WEEKS AGO. CHANGED PLIUG AND WIRES TODAY, IDLES WORSE.


Did you replace the plugs with the same plugs (Manufacturer) as the plugs you had in there. Some cars are very picky with plugs. ie: some Japanese cars will only run well with NGK Spark Plugs. Try to use only what Subaru recommends in your engine for ... 1999 Subaru Forester

1994 pontiac bonneville sei has intermittent very rough idle. sometimes it idles very high and the check engine light comes on, it pulls no codes when i shut it down it goes off. I replaced TPS and idle air control, throttle body and intake super clean, plugs new, wires new, coil packs new, ignition new. Recently I was cleaning the throttle body and the intake on the super charger. I read alldata that throttle body cleaner will damage it. I probably got some on it. could that be it? Any ideas?


Yes certain cleaners can hurt the throttle and injector areas 2+2 carb cleaner i have used for years as my dad and granddad used haven't had any problem. What i would do first is check for vacuum leaks with a can of 2+2 spray it every where on the in ... 1993 Pontiac Bonneville

I screwed up my 1999 Saturn SL 1.9 SOHC spark plug wiring while trying to put in new one. I tried to do each one separately but the saturn's have a wiring holder i just couldn't get apart to do this. what I need is from left to right looking at the engine spark plugs which cylinder goes to which coil terminal from left to right. There are four coil terminals Please help I am desperate. I can get the car to start and run but it runs really really rough now and I dare not drive it. Stalke


... 1999 Saturn SL

Was driving down son's dirt road driveway returning home at low speed in 2nd gear in my 1997 sunfire when it suddenly started running rough with no power. it will start right up and idle is rough but acceleration is rougher and the car bucks and the engine runs boggy. all sparkplug wires spark to the plug. there was no snap, crackle, or pop when it occurred, just rough and loss of power, car will drive in a limping wounded manner. changed fuel filter with new clutch about 3000 mi ago. checked fu


Sure sounds like a typical case of dirty/contaminated fuel....or a broken vacumn supply hose around the intake manifold area, in neutral let it idl;e and look and listen for a hissing sound, or a broken black rubber hose.\012Also have the compu ... 1997 Pontiac Sunfire

1987 gmc sierra 305 tbi. Rough erratic idle. Started after buying gas other day. half way home started losing power, then started missing. Replaced fuel filter and fuel pump. Then map sensor code 33 came up. Replaced map sensor. Same running condition. Also replaced coil. Remove vacuum line from map sensor or pvc. Idle picks up with only slight miss. Remove wires from tps or coolant sensor, same happens. Took 2 days of working on for code to show. Stayed for a while, then went away. No new co


... Cars & Trucks

P0171 and p0174 codes in memory. I had a tune up and a 4th or 5th cylinder wa not firing. The tune up included new plugs and wires and a new coil for one of those cylinders..I drove over a hundred miles with no CEL showing. Overnight, in morning, at temp of 17 degrees, it starter fine idling at 1200 rpm for about 5 min. It then started to be rough, rapidly alternating between1000 and 500 rpm. After warming up, no problem. Next morning, when starting up the CEL started flashing, I drove with the


Check the PCV line!!! there is a rubber boot that goes from the 3/8" hard plastic line to a 5/8" at the back of the intake. this boot deteriorates and will cause a P0171 and P0174 codes and will not always show signs of leaking. so do yourslef a favo ... 2003 GMC Yukon XL

1987 gmc sierra 305 tbi. Rough erratic idle. Started after buying gas other day. half way home started losing power, then started missing. Replaced fuel filter and fuel pump. Then map sensor code 33 came up. Replaced map sensor. Same running condition. Also replaced coil. Remove vacuum line from map sensor or pvc. Idle picks up with only slight miss. Remove wires from tps or coolant sensor, same happens. Took 2 days of working on for code to show. Stayed for a while, then went away. No new co


... Cars & Trucks

I have 88 ford bronco ll start and run idle rough then smooth out then get rough i replaced new fuel pump in tank and side frame new wires spark plug distributor cap and rotor new thottle position sensor


... 1988 Ford Bronco II

I have a 95 PA, base, 3.8L. Started having problems recently with stalling and it won't start back, until minutes or hours later. It cranks, but won't turn over. I lose use of windows and seat controls, and trunk release. Could this be crankshaft piston sensor, PROM chip, or something else. I'm lost. I have three new ignition modules installed, new plugs and wire, new fuel filter and other then this aggravating experience the car runs nice a dream, smooth, a little rough idling when I'm sitting


Thanks for choosing FixYa and welcome. It may be the crank but not for sure. You need fuel, air, and fire to start the vehicle. With the loss of electrical components, it sounds like you have an electrical issue. If so, they can be hard ... 1995 Buick Park Avenue

82 22-R toyota truck automatic runs fine idles fine then for no reason will not idle when stopped. I have to give it gas to keep running but runs rough. New plugs,dist. cap, wires, & rotory button. Some days runs fine then acts up. Some days starts out bad then starts running good.


I would suggest also replacing all O2 sensors, PCV valve, air filter, fuel filter.. Just might clear it up.. Not expensive and if issue continues - you will have ruled all that out as a cause..\015\012\015\012Have a nice day ... 1983 Toyota Pickup

I have a 92 toyota that refuses to idle.. It will start right up and idle rough for approx. 5-10 sec. then it will die. New plugs, new wires, and fuel in the tank.


... 1992 Toyota Pickup

1992 Lumina Backfire - I have a 1992 Lumina Euro, 77K miles, 3.1 V-6. Under moderate to hard acceleration the engine will backfire and you can smell gas. The spark control module, coils, wires, plugs, ECM, crank sensor, Idle speed motor, throttle position sensor, map sensor, EGR valve, injectors, intake gasket, fuel are all new. The car starts up and idles ok, a tiny bit rough, and runs / drives ok unless you accelerate then starts to backfire around the 3000 rpm range, if you back off th


I know you mentioned the EGR valve has been replaced, but you may have a bad 'new' part. I know the car is electronic, but has anyone checked its ignition timing (timing belt been looked at, I know it only has 77k on it). Is the fuel pressure regulat ... Chevrolet Lumina APV

Hi, I,m having trouble with my 95 Saturn SL2. It has been running fine for years now for the last year it has been running rough onces it get up to oprating temp. It starts up alright but once the temp goes up the idle starts becoming irratic. From time to time the idle with go down so slow it will stall out. I've changed the plugs, wires, distributor coils, EGR, and a sensor on the intake manifold. I've cleaned out the throttle body and ran injector cleaner thru the fuel system and the injector


Try replacing a valve called the Idle Air Control Valve, if your car has one. See if that solves it. Not sure where it is located on your specific vehicle. ... Saturn SL2

2000 ford f150 160,000 miles. Had to replace fuel injector #2 cylinder 3 years ago. Recently, started getting rough idle and obvious misfire. Check engine light (cel) code 0302. Put in new plugs, wires and coil pack. CEL off and no misfire or rough idle. How do you know if this soved the problem or an injector is going bad. Too hard for a DIY to change fuel injector. #2 problem. Seat belt giving 27 code. Can't locate problem #3 problem! Odometer comes on and off at will. S


... Ford F-150

Had water pump and timing belt changed car ran good before the change. just installed new plugs and wires . car idles horrible.runs good over 1000 rpms but when you stop car idles extremely rough. is it possible to be a little out of time. im getting no backfire or no start like usual out of time scenarios. could it be vacuum or maybe a pinched wire. please help.


It could be a broken or unhooked vacum line but i really am gonna go with the timing being out a couple of teeth it thats the case the car would idle rough and and stumble plus lack a bit of power on take off. if the timing is off the comptuer will c ... 2000 Dodge Stratus

Hello, i have a 1994 firebird, 3.4 V6, automatic, car will start but runs really rough, will barely move, reverse or drive, throttle on floor can't hardly pull in garage, started losing power slowly over time, replace plugs,wires,fuel pump,fuel filter,air filter,idle air control valve,knock sensor,some vacuum lines, checked- tps, cmps, ing. module and wires, fuses, fuel lines, still running bad, about to replace both ckps, fuel cap, and harmonic balancer. anyone have any other suggestions what m


... 1994 Pontiac Firebird
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 4.6005 seconds