Having problems with your 1993 Mitsubishi Diamante ?

Put in new spark plugs but now engine ''hunts'' at speed and seems like its mis firing and runs roughly . Its a mitsubishi Magna TR 2.6 l efi

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Make sure the parts guy sold you the right spark plugs for your car.\015\012\015\012\015\012Make sure you got the right gap and make sure you put the plug wires back on securely and in the correct order.  I usually do one plug at a time so I don't mess up the order.
Sound like you have the wrong spark gap.it should be 0.039 - 0.043.also bad plugs wires will cause problems.
Repair Help & Product Troubleshooting for 1993 Mitsubishi Diamante

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Put in new spark plugs but now engine ''hunts'' at speed and seems like its mis firing and runs roughly . Its a mitsubishi Magna TR 2.6 l efi


Make sure the parts guy sold you the right spark plugs for your car.\015\012\015\012\015\012Make sure you got the right gap and make sure you put the plug wires back on securely and in the correct order.  I usually do one plug at a time so I don ... 1993 Mitsubishi Diamante

I have a 1998 Chevy K1500 with a 350 and it runs rough from time to time and has a mis fire on #6


Looks like you covered just about everything outside the engine.Since it has 225k on the engine, its possible the valves are carboned up or burned to where one of the intake valves fail to close some times.You might try a compression test or ... Chevrolet 1500

Timing issues thought timing belt was going out but took apart it was ok car still clanks like out of time but it is not was running with a little mis fire for a couple of weeks but ran ok shut it off at a resturant came back out started it thats when it started clanking like a timing belt but took off valve cover everything seems ok there


This is a common issue in ford escorts, and I hate to say it but your cylinder head is bad.\015\012I've personally seen this issue on over 20 ford escorts ranging from 1991 to the present.\015\012The cylinder heads are made of cast-alumin ... 1998 Ford Escort

I have had white smoke coming out on my Starts for few weeks then it goes away then today Car started & was rough like mis-firing 7 then engine light came on was rough on hills & engine light was flashing also a few times too to shop for them to run a check on it ??


Take to a shop and have a compression test done. It is likely you have a leaking cylinder head gasket. ... 1999 Toyota Camry

My yukon runs rough when put into reverse or drive like it is miss firing also does it when stopped at light, seems to run fine while driving it. had codes pulled p0200, p0178,p0179


... 2002 GMC Yukon XL

It seems like the injector is having problems one of the cylenders is not firing and is has a los of power and seems to run rough what could be wrong


Look you are looking at a number of things when a Cylinder, it can be electrical,1 like the spark plug can be not working, 2 the distributor cap if the car has one, 3 The spark plug wire that runs from the distributor to the spark plug that spouse n ... 1992 BMW 5 Series

The engine runs rough, vibrating. it has power and will go but when idleling it runs rough. also it seems like the fan is running all the time and is really loud. and it smells like sulphur or like the smell of a match after you blow it out. cant seem to keep water in it but i dont see water leaking anywhere. help


Sounds like you have a blown head gasket. Look at your oil dipstick. If it has a frothy looking brown substance on it, it is probably water in the oil. Also if you can see the coolant in the plastic reservoir where you put coolant in, see if there ... Ford Windstar

1997 Ford F150 6 Cyl 4.2 liter Is running rough almost like a mis fire. Can not get a read on it at Auto Zone. Replace Spark plugs and Wires still doing it. Now What?


Have you cleaned the soot from the throttle body assembly,or check what the fuel pressure is while it's running ... 1997 Ford F150 Regular Cab

2006 Ford F150 5.4Liter 3 valve 70,000 miles. Started running rough and whistling noise during acceleration or engine lugging, Missing and no power at shift points, engine would pop, NO CHECK ENGINE LIGHT. AutoZone scan showed bank one rich cylinder # 2 and #3 miss fire. Changed plugs (Thats Another Stroy) seems to be worse. Replaced #2 and #3 coil no change.Whistling noise or air pump noise form paasenger side exhaust sounds like cylinder #3. I'm lost. NO CHECK ENGINE LIGHT. PVC valve?? Hea


... Cars & Trucks

How to do valve timing 1973 Monte Carlo. running ok past year but increasingly rough; edelbrock carb just cleaned; backfiring out the intake manifold. Could this be a timing problem? Seems like the valves are closing before it fires causing it to backfire.. any suggestions would be appreciated.


Or a flat lobe on the camshaft. ... Chevrolet Monte Carlo

Running rough at idle like a miss fire seems to happen after quick acceleration rev engine fault clears bmw 740i


... BMW 750

Check engine light is on and it runs rough like it is mis firing on a plug


Change the coil pack.if plugs are ok. ... 1999 Oldsmobile Silhouette

Running "rough" My 2001 Chevy Venture currently has 108K miles on it. Today, it started running rough, feeling like it was about to die during idling and taking off very slow, running rough and bumpy. At around 20 mph it seemed to get smooth and normal. My instict is to get the spark plugs, plug wires and distributor cap changed as it feels like misfiring plugs, but I'm not certain.


I had the same issue with my venture. It turned out to be the number 5 plug wire, backside of engine ended up breaking out of the plug carrier and burning in half on the manifold. Your best bet is to trace all the wires to start off with and change ... 2001 Chevrolet Venture

I have a '94 accord LX 5-speed with 111k miles. When I drive above around 70ish mph, the car starts to run a little rough, it begins to shake a little. There is no CEL light on and the oil was just changed. It seems to run fine under 70 mph and at various RPM's. It does seem to idle slightly rough lately, but NOT badly. The temperature gague is not reading hot when this problem occurs. This car seems like it may have sat around for a while before I got it. Thanks to anyone that can help/ reads


Seem like you need to have at-least the two front tires high speed balanced. This shaking at high speed is most likely due to the tire being out of balanced. Good luck and thanks for us ... 1994 Honda Accord

1996 Ford Windstar GL 3.8 auto trans. 209,XXX miles Bought it from someone, running just a little rough, like it was running on 5 cyl, blowing white smoke. Previous owner stated it needs a head gasket. I agreed that it seemed it does. Oil had coolant in it. Didn't seem oil was reaching the coolant though. We found the burned up head gasket and replaced it. Put everything back together, now it's running worse than before, more rough, barely has any power to rev up, and stalls, also making a "clac


It does not sound good its possible with that high mileage the engine has internal damage.Also if you did not have the cylinder heads checked by a machine shop that could pose a problem also.We have replaced so many of those engines that i could not ... 1996 Ford Windstar

I have a 1992 Corsica, 3.1, v6, automatic, all of a sudden idles extremely rough, have to push gas peddle way further to make it move, has a funny smell, possibly small amount of water in oil, (only shows up right after engine has been running and on first dipstick only) doesnt seem to be shifting right, idle in gear is so low and rough car seems like its gonna die but doesnt, seems like low pitch popping sound from tail pipe when in park. i read your previous q & a's and possibly head gasket bl


... Cars & Trucks

My buick Century (2000) is running ragged and rough.. (Started sunday) and the Service Engine light is FLASHING!!! --Service Engine light has been on, but it has never flashed. I notice when i speed up a little bit--the car seems to run better but when I slow down or begin to take off you can hear that sound much more noticeable..and the roughness seem to vanishes after it has pick up speed.. I have change the wires, plugs, and the one of the coil packs (3*6)..It is still not running like it sh


... Buick Cars & Trucks

My blinkers only work when they want! This has been going on for a very long time.. also when I turn it on to go any where ill pull out of the driveway and go to accelerate it seems like its slow and it feels like its delayed or chugging it runs very rough. When I sit at stop lights I feel like its gonna die so I always put it in nuetral so it doesn't run so rough.. and my left headlight always goes out! Even a day after I put a new bulb in it loosens and has to be tightened. Also, one of my cyl


I had the same problem with mine if you mess with your hazard light switch wiggle it etc. it's all connected in 1 curcuit it fixed mine. ... 2001 Oldsmobile Alero

I have a 2002 sante fe 6 cyl I can not seem to get the firing order right I have it 3 6 2 5 4 1 like everyone is saying and it still wont run right pops while running and running like it is crossed firing ant suggestions ..


Firing order 123456 ... Hyundai Cars & Trucks

1999 chevy s10 blazer had to the shop twice first time running rough eng. lite on smelt like salfer shop hooked up to comp. said cyl. 6 miss fire ran a eng. vac on it or others words injuction cleaner. ran ok for a while last week started running bad again took in said cyl. 1 miss fire so thay ran an other eng. vac. on it check light went off and with in 2hrs ran rough again and eng. lite back on and died got it going took to shop said cyl. 1 miss fire what should i do know tried of spending all


Can't say for sure that its a definite fix, but sulfur smell generally indicates a catalytic converter failure. Running injection cleaner through the system will sometimes also partially clear the problem in the cat but it quickly returns. If the sho ... Chevrolet Blazer

Running rough, like not firing


Your "catalytic converter" is becoming clogged. The exhaust is not properly escaping, and the problem will get worse. A new catalytic converter will cure the issue. ... 1997 Chevrolet Cavalier

I have a '03 Toyota Celica GT-S with a annoying mis-fire. Started small by replacing all spark plugs - nothing. Replaced the MAF sensor - nothing. Took it to a authorized toyota shop & checked compression which check out good and put the computer on. Computer read mis-fire on cylinder 1, and then multiple misfire (like it would jump around). We went ahead and replaced the fuel injector on cylnder 1 - did not solve problem as when we hook the computer up, misfire seemed tp stay at idle and seem b


Replaced the MAF sensor - nothing. Took it to a authorized toyota shop & checked compression which check out good and put the computer on. Computer read mis-fire on cylinder 1, and then multiple misfire (like it would jump around). We went ahead and ... 2003 Toyota Celica

I have a 2000 E46 BMW 318i. The trans light is on showing it is in back up mode. The down changes are extremely harsh even in manual mode. At same time vehilce started to stall at idle and at one stage wouldn't start, would just fire and then stop. Seemed like an air sensor or something, not flooding but had to run it at about 2000 rpm until it settled down. After trying it several times it started and seemed to reset itself and now runs OK but trans problem still there. Is this likely to be con


Steptronic is a option and not all BMW has it. If this manual gate fails,the steptronic shift will not occur.If the switch up switch fails then there will be no up shift response. If the switch down switch fails there will be no down shift response. ... 2000 BMW 3 Series

When i try to start my motor it fires and dies like it backfires but want run, I just rebuilt the motor and it was running OK, but it was not charging battery so i checked the stator it had a broken wire i replaced it and when i started it up again i had this problem plus i here what sound like spark from coil and coil lead, i disconnected the rectifier and stator from the main (RED WIRE) to see if that made any change ''but no'' my plugs seem to spark OK but not continuously they seem to go, st


Are you still using points and condenser? If so try and replace as if they are not new and set correct gap it wont complete the circut. Cracks in the cap and a bad rotor can be causes also. ... Mercury Mariner

2001 F150 While driving in light rain engine died comming to stop. Attempted to restart and acted like low batterry (no tick just slight turn and stop). Twenty minutes later It had slow crank and attempted to run but extremely rough like firing on two cylinders. This morning again slow crank and extremely rough trying to run. Temps were good, Battery full charge, and I did not drive threw any big puddles. Any suggestions?


AUTO SHOP OWNER\012\012\012Welcome to fixya\012\012Hello\012\012 \012\012I hav ... 2001 Ford F150 Styleside SuperCrew
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 3.3269 seconds