Having problems with your 1993 Isuzu Rodeo ?

Trying to find the mass air sensor on a 1994 Isuzu Rodeo--recently replaced the motor with one from a 1993 Isuzu Rodeo.

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Between the air filter and the throttle body
Repair Help & Product Troubleshooting for 1993 Isuzu Rodeo

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Trying to find the mass air sensor on a 1994 Isuzu Rodeo--recently replaced the motor with one from a 1993 Isuzu Rodeo.


Between the air filter and the throttle body ... 1993 Isuzu Rodeo

I have lost a lot of power with my 1995 Isuzu Rodeo. This issure was going on when my father gave it to me. I took it to a Honda dealership for repair. It ran great for 3 years and now I am having the issure again. I replaced the spark plugs and wires. New air filter. Cleaned the mass air flow sensor. It looks as if oil is getting in and fouling one or more of my plugs. I went to dealership to ask what all they replaced. The tech said it soulded like my ''rocker seals'' have gone bad. They repla


This is what the print out of the work order says.\015\012" Replaced all 6 spark plugs, spark plug wires, coil pack for 1 & 4. Rrelaces all 6 spark plug gaskets. Replaces timingbelt tensioner. Replaced timing belt and all ext. belts. Servic ... 1995 Isuzu Rodeo

Throttle When I apply the gas pedel it acts like its starving for air. I pulled the air filter out but sounds the same. I have replaced the fuel pump, fuel filter, cam position sensor, plugs and wires and replaced the MAF sensor tho with another used one. One relay seems to click alot after I shut it off and the solonoid for the vapor can rattles at times. I also replaced some vac lines but like to find a vac diagram?


What is base fuel pressure at idle ? ... 1991 Buick Park Avenue

97 Chrysler Concorde high idle speed A 1997 Chrysler Concorde starts fine, but idles at 2000 rpm. The idle increases to 2500 as it warms up. Vacuum is at spec, and no signs of intake leak. We have replaced the coolant temp sensor (previous code), idle air control motor (previous code), one front O2 sensor, EGR valve and control, and MAP sensor (previous code). The previous owner had the PCM replaced with a used unit, with no luck. We have not yet replaced the intake air temp sensor,


Couple things to check out. what is the throttle position sensor readings fully closed (should be .5volts). if it's above the pcm may think the car is not at idle. did you spray sections of vacuum lines and manifold gaskets with brake clean to check ... Chrysler Concorde

Recently bought 2004 isuzu rodeo the ck engine light stays on had it ck'ed showed the throttle sensor took it to shop they said couldn't find a problem with it and said it would cost about a 1000 to replace. vehicle runs really well if you take breather off and move some of the wires the light will go off but it will come back on. what could the problem be ?


The wires that you move, probably have a bare spot on one of them shorting out. check every wire carefully. Wires tend to break at the plugs so check there also. Give them a tug, one at a time you will find the problem. Of course do this while the ca ... Isuzu Rodeo

Ok so my 02 mustang gt was throwing a code forever, witch was P0113, intake air tempature sensore high input. after finding out my intagrated iat sensor was malfunctionaing i replaced it with a external one on my cold air intake. ever since then ive been getting codes P0171 and P0174 both banks system running too lean. i can not get them to go away. ive tried checking the fuel pressure. the fuel filter was changed i cleaned my MAF checked for vaccum leaks didnt find any fuel injectors are work


... 2002 Ford Mustang

I have the following codes 1999 Izusu Rodeo: P0137 O2 SENSOR BANK 1 P0137 O2 SENSOR BANK 2 P0171 SYSTEM TOO LEAN BANK 1 P1171 MANUFACTURE CONTROL FUEL AIR METERING P0174 SYSTEM TOO LEAN BANK 2 P0452 EVAP EMISSION I HAVE REPLACED; EGR VALVE; MAP & MAF SENSOR; o2 SENSORS 2 BANK ONE AND TWO; THE PCV VALVE....? WHEN COLD STARTS it SHUTS OFF A FEW TIMES THEN WARMED UP IT IDLES FINE. NO DIFFERENCE AFTER REPLACING ALL ABOVE PARTS...IT STILL HAS NO POWER WHEN DRIVING? DONT WANT TO GO TO THE DEALERSHIP!!


I have a van that had a similar problem. Not sure if the rodeo has O rings. That was my problem. ... 1999 Isuzu Rodeo

Colin, hello Hey, My son has a 2001 Honda Civic Standard .... The motor went bad and we picked the option to have an Authorized Honda dealership find a replacement engine and install. This engine came with a 6MO / 6,000 mile P&L warranty. The replaced engine went bad in one week and the Honda Dealership found another engine to replace the second one with. This replaced engine now has a bad Air Valve pump and a bad Electric Voltage regulator [ alternator ? ] which the Dealership is asking m


Sounds to me like these came on the replacement engine and should be paid for by the dealership, didnt they keep the old engine and why cant they take the parts of it? ... 2001 Honda Civic

2003 Honda civic ex, low idle or air flow issue causing shaking. I replaced the air flow sensor, replaced motor mounts, had a tune up down, flushed radiator, changed air filter and still cannot stop it from shaking a idling low at times . Any suggestions? Only other one I've been given so far is to change out the catalytic converter for better airflow.


... Cars & Trucks

I originally have my 97 honda crv motor replace by a 99-00 motor...but the new one has a knock sensor, while my old one doesnt! Dont know if that matters...it was fine the first couple of days...but now, its hard to start the car no matter what condition...i would have to step on gas and hold it for awhile until it warms up...check light says idle air control...changed that already and yet still the same problem...what can be the problem?


Did you use the The fuel injection, mass airflow sensor, throttle position sensor,, etc. from the old motor? If not, then there may be a conflict with the computer or engine management system. If you just swapped the complete motor, then you will nee ... 1997 Honda CR-V

93 dodge caravan - fan was not coming on and the air conditioner will not come on. replaced fan, radiator, coolant sensor and thermastat. Checked all relay's i could find, checked all the fuses in the fuse box. still fan and air conditioner will not come on. Any ideas about what else the problem can be? (people tell me there is a fuse somewhere under the hood, but i cannot find one anywhere!) thanks


The fan is protected by a fusible link. Follow the power wire from the fan backward until you find the fusible link. It will feel mushy if it is blown. ... 1993 Dodge Caravan

Ok this is a long one but i apologize in advance. i purchased a 2000 mercury cougar. i replaced the motor with a used motor because a rod was knocking. since then i have replaced the alternator and battery, power steering pump, water pump and thermostat, and mass air flow sensor. now the car cranks but rattles a little until the idle settles and the check engine light is on. my brother hooked a diagnostic computer up to it and the code was 0198. i cannot remember exactly what it said beside the


WELL YOU HAVE 2 DIFFERENT 0198 CODES. CODE 0198 ENGINE OIL TEMPERATURE IS HIGH OR CODE 0198 FUEL RAIL PRESSURE SENSOR CIRCUIT HIGH INPUT. ... 2000 Mercury Cougar

My 97 cavalier cuts off when it goes in reverse. I replaced the idle air control sensor which the diagnostic told me to do and it still cuts off. I still have to replace the oxygen sensor but is that really making it cut off another mechanic told me that I needed a motor mount because that was making it cut off, no one is telling me the same thing and I am very confused please help me


Check the motor mounts first. ... 1997 Chevrolet Cavalier

I cant I have a C230 '98. I just recently replaced the mass air flow sensor and I was driving with a broken one for a few months. Now the check engine light is off but the car lunges forward sometimes when its cold when it switches to second gear. Sometimes its one sometimes its more lunges...like the air gets sucked out of it n it loses power for a milli second. That's what it seems like. Is that the tranny itsself or a lesser problem like trans fluid or something?


Try removing the positive battery terminal for 10 mins then putting it back on, drive it around for a while after that and see if the problem disappears. When you were driving with a bad MAF sensor it may have adjusted your A/F ratio's to this and no ... 2001 Mercedes-Benz C-Class

GMC 2003 2500 savana. Engine light was on checked it fuel bank 1 & 2 o2 sensor / maf sensor. replaced maf sensor, 3 o2 sensors, tuned up, fuel filter, and the light comes on and goes off, runs like a lug when its on.... I checked for air leaks couldnt find one? any ideas?


... 2003 GMC Savana

My 2000 Isuzu Rodeo occasionally Cuts off when breaking or just sitting there idleing, I have took it to 3 different Mechanics, 1 said EGR Valve, so i replaced it Problem still Persist, 2nd said Mass Air Flow Sensor replaced Problem still persist, And the 3rd says the throttle body but not positive but i have not replaced it because the price of the throttle body over $350, So i am hoping someone might have a better cheaper solution,


Idle speed control not working or idle too low.if all good check fuel pressure.if it been a while change fuel filter. ... 2000 Isuzu Rodeo

Got 97 ford ranger 2.3 rough idle has not died on me but will drive down road like normal but lil jumpy it is throwing codes for egr valve , mass air flow sensor, o2 sensor, so I put new ones on, I put new vacuum lines on almost all but can't find no leak also replaced egr sensor


... Cars & Trucks

Revs high Hello, I have a 2001 Ford Focus Automatic 2.0 DOHC Zetec 125,000miles. I recently bought this car about 3weeks ago. Car struggled to move and idled rough... The TPS that was on the car, everyone was telling me it was for a manual vehicle, and the one for auto didn't match up to mine. This is all I've replaced so far... Throttle position sensor factory motor craft one for automatic with a used Throttle body from junk yard, idle control valve, fuel filter, plugs and wires and ign coi


If the idle speed is normal until you shift into a gear, the idle air control valve is probably raising the idle speed. Try unplugging the iac motor at idle then shift into drive.If the IAC is raising the RPM the computer controls it, so for so ... Ford Focus

My 1999 isuzu rodeo is not staying started unless you kep the throttle pushed down ive replaced the throttle position sensor, mass air flow, and idol air control and is still not wanting to stay started weve also adjusted the throttle cables and it works for a little bit and then i try to start it again later and it still does the same thing


May want to check fuel filter and replace it,its a cheap fix like 11 bucks ... 1999 Isuzu Rodeo

I have 1991 Isuzu Rodeo with a 3.1L V6 TBI. The car will start but almost immediately stalls. The injectors are pushing fuel. In order to keep it running, I have to give it gas. I have tested the throttle position sensor, map sensor, idle air. They are all fine. Also the fuel pump is working properly. I also replaced the pick up coil. Even after all this, it continues to run the same way. I am out of ideas and could use some thoughts as to what else to look at.


... 1991 Isuzu Rodeo

At elev. 8500 severe power loss under load. Live feed engine data as follows:0-5 engine timing retarded,pending code fuel system fault OL and sometimes will set mass air flow code. mass a sensor replaced recently. removed air filter resonator from behind bumper,left top portion w/filter element in place. once vehicle returns to lower elev. runs great.will not set code again until returns to 8k .vehicle 30k mi. org. owner.have own scanner w/live feed.


Does your scanner give you a reading for barometic pressure? ... 2001 Hyundai Sonata

I am replacing the vacuum hoses on my isuzu truck. I am doing it one at a time, but I have one port that I cannot find.....the small hose that comes off the bottom of the air cleaner. I think that what I need is a diagram of the whole vacuum hose system.


SOUND LIKE A VACUUM HOSE THAT CONTROLS THE THERMOSTATIC AIR DOOR ON AIR CLEANER.THE HOSE SHOULD GO TO THE THERMOSTAT IN AIR CLEANER.AND THEN OTHER HOSE TO THERMOSTAT CONNECT TO VACUUM PORT OR VACUUM TEES ON ENGINE. ... Isuzu Pickup

Have a 99 malibu...replaced motor..replaced intake gasket on motor before installing..everything went good..one problem now I have good great heat one day and no air, then the next day good air no heat.....? Also put new stat and water pump in the motor


You may want to flush you heater core:the heater core is in the dash inside the engine.\012 But open the hood and look on the firewall of the car. There should \012be 2 rubber hoses going into the firewall and ... 1999 Chevrolet Malibu

I have mazda 323f 1.3 petrol engine 2001 model(UK). It seems to be misfiring and is very sluggish uphill. I have replaced the spark plug leads but this has not cured the problem. You can feel the car is juddering at low revs and the rev counter keeps moving up and down on idle. Somebody suggested replacing the air flow sensor. The problem seems to be confined to one particular cylinder. If the airflow sensor was faulty, would the problem be isolated to one particular cylinder? The air flow senso


I cant solve this problem but i also could use the solution. As i was driving this morning the same thing happened to me. I would put myfoot down an nothing was happening it would only get up to 40 an then the check engine light came on flashing so i ... Mazda 323

1999 Chrysler 300M, Dies on deceleration and at idle when warm. I can some time see the tach go to 0 rpm, with out the car actually dying I have had may suggestions, from EGR, throttle Body, fuel injectors, fuel pump, cam & crank sensors and more, I really would not prefere to just start replacing parts untill I find a solution. Has any body found a fix for this issue, I have seen many posts with similar conditions, but so far not a single one that says the problem was fixed...


For the price of a can of throttle body, spray cleaner, I'd remove the IAC motor , clean it, and port it came out of and try it and see what happens. It sure sounds like the same old dirty IAC problems that are frequent . Normally that will cure it, ... 1999 Chrysler 300M
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 4.9327 seconds