Having problems with your 1993 Dodge Dakota ?

Wondering what else we need to try: Our truck runs very rough-cuts out and cannot go very fast (maybe 25- tops). We have had a few different people work on it and they have put on new parts. We have put on a new pick-up assembly, new spark plugs & wires (whole tune-up kit), replaced gas lines, changed oil, and most recently replaced coil and wiring to the coil. They also checked the timing, and compression, and adjusted dist. pickup syn. sensor. We have also tried "Heet" in the gas tank. A

Posted / edited by AnonymousUser on : 22-01-2018

Answers :

Check the catalytic converter on the exhaust. They are bad about getting clogged up on a dodge. If they clog it will make your engine run poorly and have no power due to little or no exhaust flow. Its a pretty common problem.
Repair Help & Product Troubleshooting for 1993 Dodge Dakota

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Wondering what else we need to try: Our truck runs very rough-cuts out and cannot go very fast (maybe 25- tops). We have had a few different people work on it and they have put on new parts. We have put on a new pick-up assembly, new spark plugs & wires (whole tune-up kit), replaced gas lines, changed oil, and most recently replaced coil and wiring to the coil. They also checked the timing, and compression, and adjusted dist. pickup syn. sensor. We have also tried "Heet" in the gas tank. A


Check the catalytic converter on the exhaust. They are bad about getting clogged up on a dodge. If they clog it will make your engine run poorly and have no power due to little or no exhaust flow. Its a pretty common problem. ... 1993 Dodge Dakota

Hi i have a 95 ford f-350 it doesnt shift into third gear. i put a new sensor on it when i first got it because it was doing the same thing which fixed it. next i went off roading with it and got alot of water into the transmission. now it wont shift into third again. i put a new filter and oil in it to see if that was my problem but it isnt. i also put a new sensor in the rear end and that wasnt my problem. then i replaced the sensor on the side of the trans and it still doesnt work. i got th


... Ford F-350

Why would there be oil in my cold air intake in my Blackwood? It runs but barely and extremely rough idle. I thought I got some very dirty gas from a gas can my husband used to put gas in it after he changed the oil.We put a new massflow sensor in it and found oil in the air intake area. Also, the pcv valve was loose? Any help would be welcome and much appreciated. Thanks ..... I so love my truck!!! Diana S. Nebraska


When oil is found in the intake it is most likely the pcv is malfunctioning. You say it is loose. The rubber it is seated in may be bad now that it has oil on it. You should replace the pcv and the rubber that it is seated in. If the problem continue ... 2002 Lincoln Blackwood

I just tested my spark plugs, and two of them are not sparking as bright as the other two. The car just recently ran out of gas. I replaced the fuel filter. The fuel pump IS good. NO fuel regulator leaks. MAP sensor is good. Put a new temp. sensor in it. And a new clutch. This didnt start happening until i ran out of gas. Also, It boggs down BAD at low RPM's. Please help!! Thank you. I will rate whoever answers this. :)


It could be many things. Do you have any engine lights on? It could be a fuel pump going bad, two bad(clogged) injectors,blow fuses, a bad ecu,bad o2 sensors...etc. These cars are known for have expensive problems. Try to get to autozone and have it ... 1996 Saturn SL

I just tested my spark plugs, and two of them are not sparking as bright as the other two. The car just recently ran out of gas. I replaced the fuel filter. The fuel pump IS good. NO fuel regulator leaks. MAP sensor is good. Put a new temp. sensor in it. And a new clutch. This didnt start happening until i ran out of gas. Also, It boggs down BAD at low RPM's. Please help!! Thank you. I will rate whoever answers this. :)


Well, you can try lightly sanding the contact point ( where the spark is inbetween the gap). If that doesent help at all, just to be certain that there is another issue, take one of youre good spark plugs and insert into the wire where the spark isnt ... 1996 Saturn SC

I just did a few repairs all at once. I replaced the oil pan gasket, oil filter and oil. I replaced the transmission fluid filter, transmission pan gasket and transmission fluid. I put in new spark plugs, spark plug wires, rotor and rotor cap. I flushed the cooling system and changed the heater hoses, the upper & lower radiator hoses, the temperature sensor and the thermostat. I also replaced the valve cover gasket. When the engine is started now. There is a loud tapping noise that seems


The tappets are usually oiled via hydraulic lifters that pump oil up the push rods. I'm assuming you have the gas engine V-6 or V-8. When you changed the valve cover gasket(s), did you do anything else under the valve covers? It seems unlikely that ... 1994 Jeep Grand Cherokee

97 LicolnLincoln Continental P0131Continental P0131 and P1131 02 sensor codes. Car has a 4.6L V8 with 79K. Conti idles and runs great even with this error, but since I got these codes the gas mileage has dropped from mid 20’s to 10MPG. The car seems to run hot as the radiator fans kick on every couple minutes. I replaced bank 1 sensor 1 heated O2 sensor, new air filter, plugs, wires, PCV valve, oil, oil change, and cleaned MAF sensor. I also checked for vacuum leaks with nothing found. Al


If Im not mistaken that code is due to a lean mixture which in turn can cause an engine to run hotter.Have you had the line pressure checked for the injectors. If you have pulled all the spark plugs are there some with colors different to others? Try ... 2005 Ford Lincoln Continental

1987 chevy s10 fuel injector problem. Install new fuel injector but fuel comes out steady causing engine to idle high and bog down when i step on the gas pedal. i have previously replace swapped ecm and checkeed fuse. ecm has 12v fuses good, i also replace frul pressure switch, map sensor, o2 sensor, trying to find out why fuel comes out steady of injector and not spraying as it should. note: this is the second injector i have put in


Check the fuel pressure at the shredder valve, you should have 13 to 13.5psi, anything other then that will give you problems in the GM TBI. If the pressure is bad, then you may have to replace the fuel pressure regulator at the bottom o ... 1987 Chevrolet S-10 Pickup

1991 Saturn SC - doesn't pass the HC portion of emissions test at cruise. The #'s @ idle are high as well. Also, and possibly related, while in park & rpm's @ approx. 1700 - the car cuts out & stalls. It also hesitates while driving. I have replaced the MAP sensor, O2 sensor, air filter, EGR valve air ctrl solenoid & partially smashed the top of the EGR valve itself. The last item has helped steady the idle. I've put good new gas in it, ran XLP fuel additive thru it & ran some sea foam thru it a


Hi! Two things to look at to pass the emissions test. First, the ECM (engine control module) must be replaced for this controls the air and fuel mixture of the car. If the ECM is faulty you will fail the emissions test. Second will be the MAF (mass a ... 1991 Saturn SC

I have a 19996 lincoln towncar, which deaccelerates (driving at 75mph, then drops to 55mph, while I'm pressing on the gas). It also, hesitates at startup. How do I fix this issue? I have done the following things; tuned it up; new plugs and wires; replaced 2 front o2 sensors; changed the oil and pcv valve; replaced the fuel pump; replaced the air filter; replaced the fuel filter. What is next?


Try wires or ur coil packs very important these go often really a headache good luck,or idle air control valve,or purge valve these control hesitation and acceleration too. good luck ... 1996 Lincoln Town Car

I have an 88 chev 350 5.7 liter fuel injected truck, the timing is great. the spark is great. the valves are great the plugs wires rotor and dist are great , it should run, i replaced the fuel filter sending unit and pump, even put a new o2 sensor in it, but its getting way too much fuel and now it wont even run, oh ya and my compression is great , what the hell, i had to do another oil change couse there was about a liter and a half of gas in my oil


I had an issue much like this with my Montero. By accident I found that four of the six fuel injectors failed, leaking heavily. In my case I could get the truck started after it sat several days (drying the cylinders out) after which it would run tho ... 1988 Chevrolet K3500

CAR IS ACTING LIKE IT DOESN'T WANT TO SHIFT.WHEN IT DOES IT JERKS OR I HAVE TO LET MY FOOT OFF THE GAS AS IF IT'S A STICK. I'VE CHANGED OUT BOTH IGNITION SENSORS (THIS WK), ALL SPARK PLUGS (ABOUT 6-9 MONTHS AGO) AND THE TRANSMISSION SENSOR (LAST DEC). I CHECKED THE TRANSMISSION FLUID AND THE OILS BEEN CHANGED. THE HEAD GASKET NEEDS TO BE REPLACED AND NEW MOTOR MOUNTS NEED TO BE PUT IN. OTHER THEN THAT I'M NOT SURE WHAT TO DO OR WHAT'S WRONG WITH IT. PLS HELP! THANKS MJ


... 2001 Hyundai Sonata

Oil Leak My car is having a constant oil leak, and it looked like it was coming from the oil pan so we changed the gasket on there, the outside of the oil pan was covered in oil, but its still leaking, we also replaced the oil filter assembly where the filter hooks to the engine we replaced that gasket, also the oil filter also put in new spark plugs, checked the engine compression which was great , and we replaced the distibuter cap and rotor, still leaking do u guys have any ideas what could b


Have you replaced the valve cover gasket?  The oil filler gasket in the cap?  The o ring on the distributor shaft?  The front crank shaft seal? and last the rear main seal. ... 1996 Volkswagen Jetta

I have a 1997 monte carlo and the car is always 'dogging' when i accelerate. it takes forever to get the car up to speed. i have a new catalytic converter, a new gas tank. i have also had the fuel injectors replaced, the spark plugs and wires replaced, all the coil packs replaced. the module that the coil packs sit on has been replaced, the crank sensor replaced, the computer replaced, the mass air flow sensor replaced, the throttle position sensor replaced. i have had multiple mechanics look at


Fuel pump ... 1997 Chevrolet Monte Carlo

Replaced a bad oil pressure sensor because oil press. gauge would drop to zero when letting off the gas. Now with new sensor, oil press. is good at idle but drops to zero once rpm goes beyond 1300. I've purged the oil port, check press. w/ mech. gauge (OK) and replaced oil filter, sensor electrical connector (w/pigtail) and another press. sensor. Seems to be electical at this point. Please help.


... 2000 Jeep Grand Cherokee

My car had an oil leek,fixed it,put on new timing belt,every since,,i can drive car forever and or 20 minutes and it won't re-start til it cools off,,they also put in new computer,cam sensor,crank sensor,also checked wires,its been to 3 garages,no one can fix it,,can u please help me?The car ran great til the new seal was fixed.car has good pressure.


COULD BE VALVE TIMING OFF A LITTLE.DID YOU USE A REPAIR MANUAL FOR THE TIMING MARKS ON THE CAMSHAFT SPROCKETS AND CRANKSHAFT GEAR. ... Chevrolet Metro

I bought a 1997 Mercury Cougar about 5 months ago. The Cougar only has 83,000 miles on it. Since buying it I have had the oil changed, the transmission flushed. I have also had all 4 o2 sensors replaced and coolant temperature sensor. My brother has installed a new intake manifold gasket set, new fuel filter, replaced the spark plugs and spark plug wires. The person who sold the car to me said he replaced the mass air flow sensor and it appears to look brand new. The car has been throwing out t


By your description, I tend to agree with fuel pump issue. Could be something as simple as a connection on the pump -loose ground and/or power wire or an intermittent pump. At 83,00 that's far from being "over the hill" Also just a thought, converter ... 1997 Mercury Cougar XR7

Rough running Son and I put a rebuilt motor in a 90 cherokee we had bought not running. New Motor, replaced all sensors, MAP,Crank,Anti Knock, New Dist, Stepper etc. All replaced. It starts up and dies 3-4Xs then it will run. When you hit throttle it dies out. Oddly it runs better with MAP sensor not hooked up. I have tried two differnet MAP sensors thinking I was on to something. The EGR is also new ans working. Return fuel pressure is good. I tried new computer under glove box, that didn't wor


Try checking Throttle position sensor with an ohm meter. Remove connection, put probes on pins (hit & miss on which ones, but you'll find 2 that give you a reading that increases as throttle is opened) and read meter as you open throttle all the ... 1990 Jeep Cherokee Limited

99 gmc safari, idles fine but as soon as give it gas it stalls, i have replaced Maf sensor, Map sensor, fuel pump and filter, cat. engine coolant temp sensor, tps, and intake air sensor, it will idle great but when you give it gas it chokes out, the fuel pressure is 60 when you give it gas it drops to about 55psi, oh and i also replaced the computer under the hood with a new one, i have alot of time and money in this and really can't figure out what to do next.


... GMC Safari

I had just put gas in my 2005 dodge ram 1500 truck 5.7 liter and drove about 2 miles. All of a sudden it sputtered a little bit then just shut off...the code 0522 was showing up so we replaced the engine pressure thing. It also put out a crankshaft position sensor which we replaced. It was also showing a p0113 and we also replaced that part. It still wont start. Now we are getting the p0522 code all over again and we just replaced it. What else could be wrong??? It acts like it wants to start bu


... Dodge Ram 1500

2010 pontiac g6 running to rich. I put a new upstream o2 sensor and I had the mass air flow sensor checked and that's not bad what could it be? Put new plugs in it also and I have ran fuel injector cleaner in it. Also after it sits and the engine cools it's hard to start I have to give it gas a few times for it to start. What should I do next! Please help


02 sender plus remove battery pos post reset computer ... Cars & Trucks

My car wont start in the morning i checked all the sensors they are good brand new fuel pump and all the fuses are good. my mechanic say he is stumped. i used lucus oil incase of a clogged injector still i got nothing. only time my car will start is if i pour gas into the intake. Can anybody give me some suggestions? also i replaced the fuel pressure regulator.


Some cars have a safety shut down fuel pump relay,Have you hit a big bump or had a fender bender? Oil pressure sender will stop the pump,is the fuel filter plugged,Have you cheked the fuse, is there power to the pump? Is the tank empty? Is there po ... Cars & Trucks

I currently own a 1986 Ford Ranger 2.9 V6, RW Drive. Was driving like a charm!! I was driving it yesterday morning, no problems, I parked it after 10 minutes of driving... Last night I went to start it, it kept turning over but would not fire up! I checked ALL connections ( Plugs, Wires, Battery, Connectors, Etc), 2 months ago I replaced the Plugs, Wires, Oil Change, Valve Cover, I ALWAYS put in Lucas Gas Treatment when I fill up my tank. The Alternator is also in new condition, MAYBE 1 year old


The cranking will usually sound different after the timing chain has slipped. Does it spit or backfire when you crank it? I suggest you rule out some easier things before going after the timing chain. If you are getting spark and fuel, then maybe ... Ford Ranger

I have a 2003 chevy cavalier 2.2l manual transmission, we did an oil change, all 4 plugs have been replaced and we put a new fuel filter on but when starting it turns over but does not start right away, it idles fine but if you step on the gas peddle it cuts out at about 1.5 to 2 rpms we toke the oxygen sensor off to see if converter plugged but no change oh and the exhaust runs hot! please help


Look for a dislodged or cracked vacuum tube. What you have done should not be able to cause what is happening. Exhaust is hot, the cylinder burn temps are around 2000 to 2500 degrees F. \012\012I bet you have inadvertantly created an inta ... 2003 Chevrolet Cavalier

I currently own a 1986 Ford Ranger 2.9 V6, RW Drive. Was driving like a charm!! I was driving it yesterday morning, no problems, I parked it after 10 minutes of driving... Last night I went to start it, it kept turning over but would not fire up! I checked ALL connections ( Plugs, Wires, Battery, Connectors, Etc), 2 months ago I replaced the Plugs, Wires, Oil Change, Valve Cover, I ALWAYS put in Lucas Gas Treatment when I fill up my tank. The Alternator is also in new condition, MAYBE 1 year old


I just checked you do indeed have a timing belt.\015\012Sounds like the problem,worth the cost and time to change the water pump as well since your digging into the front of the engine anyway.\015\012The tensioner should be g ... 1986 Ford Ranger 2WD
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 3.9993 seconds