Having problems with your 1993 Chevrolet Cavalier ?

Looking for the fuel rail bleed screw to hook up pressure gauge but cant find it for 1993 cavalier 2.2l good spark and turns over fine but wont start fuel rail is empty and need to check my fuel pump is there another way to do this?

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

There is no fuel pressure test port on a 2.2L.
\015\012the only way to test fuel pressure is a special tool that GM dealers have.
Repair Help & Product Troubleshooting for 1993 Chevrolet Cavalier

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Looking for the fuel rail bleed screw to hook up pressure gauge but cant find it for 1993 cavalier 2.2l good spark and turns over fine but wont start fuel rail is empty and need to check my fuel pump is there another way to do this?


There is no fuel pressure test port on a 2.2L.\015\012the only way to test fuel pressure is a special tool that GM dealers have. ... 1993 Chevrolet Cavalier

I have a 1992 chrysler new yorker fifth ave, with the 3.3L V6, it ran fine for almost 2 years, then all the sudden, it wont start... i checked for fuel pressure (at the fuel rail) and it does have fuel, i checked for spark *(using a timing light)* and no spark... i replaced the DIC (the big box where the sparkplug wires plug in) and still no dice... i've checked all the fuses and they are all good, i am now at a loss and not sure what else to check, or how to check if the DIC is even getting vol


Sound like the Coil pack. That is what supplies the distributor cap. It could also be the computer but its most likely the Ignition Coil. You can change it fairly easy yourself. I recommend you get the repair manuel for the car. i got mine for 20 at ... 1992 Chrysler New Yorker

Hello I am recently haveing a problem with my 1999 accent.. It turns over fine but the last few days it'll start in the morning and when i come home for luunch and park it i just wont start... Im thinkin its a fuel issue so i took the gas line off that runs into the fuel rail and there wasn't any pressure when i turned the key.. I've also lifted the back seat up so i can check the pump, now whats the best way to check the pump to know its working


Most likely when you found no pressure, the pump isn't working, Was there any gas being pumped out at all? three option here are a bad pump, fuel filter clogged, or your pressure regulator is bad. Disconnect the line right before the filter and have ... 1999 Hyundai Accent

1996 4.3 vortec S10. Cranks wont start when engine/ outside temp is cold. Have used starting fluid,will start and run rest of day. Fuel pmp is cycling relay is working,needed a tune up I replaced all plugs, wires, cap,rotor, fuel filter,started fine. Sat all night would not start this morning. I turned key on and off a few times it started right up. I checked for leaking injector lines after taking throttle body off and looking down in the plenum,there is some dampness is this normal?


The plenum shouldn't be damp with gas. Is it a throttle body fuel injection system?\015\012\015\012Could be a leaky injector.\015\012\015\012Fuel Meter Body & Fuel Injectors (4.3L Engine)\015\012Removal & Installatio ... 1996 Chevrolet S-10 Pickup

2007 jeep patriot turns over but wont start. no fuel to fuel rail. Would start then did ran fine for a day . shut off at work and wouldnt start again. Checked all fuses put more fuel in tank. tried battery disconnect reset. hellp


Need a fuel system chec-the gas pump and the regulator-also the injector pulses may be failin--find an honest mech that can testum with instruments ... 2008 Jeep Liberty

O2 lincoln ls check engine light & fuel gauge went to empty the next day it wouldny start replaced fuel pump & fuel gauge ran fine drove about 40 miles the next day started it up check engine light came on & fuel gauge went to empty but ran fine . i took battery cable off reset computer it ran fine . the next day it wouldnt start engine turns over assuming fuel pump is bad again 38,000 miles on car thanks ricky


You have two pumps,I guess you know that ,if you already did one. Did you check fuel pressure at the rail and check out the electronic pressure regulator? What codes are coming up and do they stay set? ... 2002 Lincoln LS

No restart 1993 f250 2 wheel drive 300 6cl. standard trans. will run fine then when you shut it off and go to restart it after a short time it sometimes wont start till you wait a wile could be 15min. or 60 min. Or if you spray starting fluid into it then it will start. every time this happins at home we go hook up the fuel presure gauge and it starts so we can never get it to stay acting up long enough to check a few things. at first we thought spark because we had fuel at the rail but have rep


Pull a couple of spark plugs when this happens & see if there wet, as in fuel. Maybe injector leakage, causing flooding condition. When engine cold, it won't occur due to added fuel needed for cold start. ... 1993 Ford F250

I have a 2000 mustang that will not stay running,,, it was running fine, i parked it for two months in the cold and didnt start it up, when i did... it wont run if u give it gas however it will set and idle. i replaced the fuel pump and fuel filter, a relay that sets on the fire wall that is in the fuel system, emptied the gas out of the tank and put fresh gas in it, and now i have been keeping it in a garage to keep the fuel lines from freezing, no check engine lights on. what do i check next


I would run the fuel pump for a little while with the fuel line disconnected from the engine into a gas can . Although you might have changed everything you might still have residual water in lines or motor. I would still put dry gas in the tank ... 2000 Ford Mustang

I need help i just got this car its a 2001 Daewoo Lanos and we put a new timing belt on and timed it up correctly and got ready to start it and it wont start. we checked plugs and they are fine, got new wires on it full of gas so decided to check the coil and when we spin it over the coil would only fire out of 1 of the 4 posts so i bought another coil for it and put it on now this coil fires out of 2 of the 4 posts and the motor spins good and got compression. also does this car have a fuel shu


Hi I"m litosshop if you get spark from two terminals and no spark from two terminal then you have a problem with the coil pack you have to be careful with replacement parts I've had similar problems and used replacement parts and finish using origina ... Daewoo Lanos

Wont start it started dying on me(check engine light would come)so i changed cap, roter,plugs,wires,coil,and had ignition modual checked out.I also changed the fuel pump.Before I changed the fuel pump, it would start and stay running for about 20 min. But now it wont start at all.Cranks great + getting pressure on fuel rail. I am at a dead end.


Well if it dies after 15 20 min, then ide check your alternator cause that's what recharges the battery. just pull it out bring it to checker or auto zone or advanced wherever you go and they can tell you if it bad or not ... 1996 Ford F150 Regular Cab

Truck ran fine but after warm would not start untill it sat for a hour or two how wont start at all I checked fueses and relays all good it has no pressure at fuel rail


Bad Fuelp Pump ... 2001 Ford F150 Styleside SuperCrew

1999 K3500 7.4 genVI wont start. Fresh motor, built myself. New coil, dist,cap, rotor, wires, etc. Ran fine for one day then died while driving. Cranks but will not run. I verified fuel pres at rail 55 psi, spark at plug, comp is good. Re-checked all timing, verifing comp stroke TDC and wires to correct location, tried moving dist 1 tooth each way. Verified all sensors to be conected. Plugged in to Mac tools Mentor and get no fault codes. did relearn of timing, etc. Still cranks will not start,


Just a thought, remove valve covers and check lifter action, also check compression ... Chevrolet C3500

I own a 1988 buick lesabre limited w/3.8 V6. Recently, car would not start. Fuel pump checks out fine. Fuel delivery to rail is strong. But there is no spark. Replaced the crank position sensor but problem still persists. Any other possibilities? I need help on this one guys. Thanks.


Ignition module under coil pack. ... 1990 Buick LeSabre

Car shut down while driving and wont restart, turns over fine. Has fuel pressure out of filter just before fuel rail. Has spark on all four plugs when turning over.( looks white however) Timing appears to be at 12-14 btdc. have voltage to injectors. I need to check the harness between the ECM and the distrubuter. Where is the ECM in a 97 sentra. this problem familiar to anyone.


How long has it been since you did a tune up? Try replacing the dist. cap and plug wires. My 240sx had a similiar problem but it ended up being the cap had a lot of corrosion inside. Mine still had spark but was to weak to ignite. Try simple solution ... 1997 Nissan Sentra

I have a 91 ranger...it has the 2.3 4cyl...it ran fine then stopped one day when iwas leavin the house...i havent been able to get it to start unless...i spray starting fluid into the intake...ive changed the fuelpump...the filter even the mass airflow sensor...and still no solution...the pump comes on...its gettin fuel to the rail...and its gettin fire....but the two wont work together for some reason...ive looked all over these forums for solutions...and ive tried everything.....i need help...


I dont think you car wants to leave your house.... maybe your injectors are bad, if the chamber is getting too much fuel you could be flooding it, and if that gas gets past your rings you have bigger problems ... 1992 Ford Ranger

97 nissan altima just started runs fine when cold when it gets warn it starts to spit and sputters giving it gas wont help, i checked plugs and there fine checked cap and rotor and they look good i even pulled the line off the fuel filter and cycled the key and it pumps fuel fine when it starts to spit and sputter it kicks out what seems like water out of the tailpipe?


Distributors are garbage on these cars change it with one at scrap yard grab 2 ... 1997 Nissan.5 Altima

3.1 runs fine then wont start if i turn it off at operating temp. Here's the thing though. in the no start situation it has fuel pressure on the fuel rail and fire at the plugs.THe computer has been replaced.ok so lets recap has a new radiator (no sensor) has a new computer (ecm/pcm) has fuel pressure on the fuel rail, and has spark! could it be timing belt? no because it runs fine no backfire through intake or exahaust. is it the ignition module? no theres spark! is it a fuel problem? no theres


HI, ok lets address each issue as your asked 1. Timing belt: since this engine uses a timing chain and it runs fine for the most part its unlikely to be the cause. 2. Ignition module: well the module not only sends the signal for spark timing but it ... 1990 Chevrolet Celebrity

I have a 03 jeep Cherokee Laredo it wont start it trys to turn over I've had a few people tell me that the computer needs to be rebooted but I'm sure how to go about that. It all started once my car overheated we thought it was the fan needing replaced so we checked it that was fine so we checked the fuses they were fine also so what do you think that it needs to be rebooted or what I desperately need help


Hi there:First try scanning the PCM in order to know fault codes stored there; turn ignition key (without start engine) On/Off On/Off On and read Pxxxx codes showed in the odometer, note this code numbers and send us details.Hope th ... Cars & Trucks

Car won't start. It died on me on my way to work. Just started to load up, drop rpms and then died. I towed it home and have been trying to diagnose it all morning. the check engine light has been on for a week. i checked all the fluid levels and they are fine and are holding their levels fine. I have established..... Fuel pressure to fuel rail power to injectors cranks fine every other electrical system on the car works (p/w, p/dl, horn, lights, dash lights, radio, etc.) cam does turn dis


The igniter... if you have no spark 9/10 times it's the problem take Distributor cover off.. turn the crank until you can take the small screw off the rotor.. take the rotor off. and you should be able to see the igniter.. its a small box looking thi ... 1998 Honda Civic

I have a 1999 ford explorer 4.0 SOHC here we go this is driving me crazy it is hard starting when cold turn on key cranks fine no problems. will not start. if you turn key off and on 4 to 6 times will then start most times fuel pressure at check is right at 65psi when at idle. when it wont start you cane go to pressure check valve push it and no gas comes out have replace fuel filter and fuel silonoid still same if i park it faceing down hill alot of times it will start right off help whats the


Hello, well at least you know the end cause is there is no fuel at the check valve. Can't really explain cold start part, except the Brain needs a signal from the Water temperature sensor to put it in a "Cold cycle" start with higher idle and richer ... 1999 Ford Explorer

I have a 1994 chevy S10 blazer 4x4, it wont start,I replaced the module,fuel pump,plugs,wires,rotar buttom and distributor cap. I can get it to start by putting fuel in intake,but it dies as soon as it burns up the fuel that I put in it. fuel to filter,(fuel filter clear,getting fuel thru it) and i am getting fuel to the fuel rail (fuel sprays out when I depress the valve on rail that is used to check fuel pressure. can anyone help me with this problem.


Try checking the fuse to the pump or the relay. ... 1994 Chevrolet S-10 Blazer

I have a 1991 Suzuki swift sedan, it wont start, we replaced spark plugs and checked the leads, it started for 2 mins sounded like it was dying and then wont start again, we have checked the water and replaced the battery, it was running fine and then it just stopped, checked the fuel filters and checked the carby, car has 220000kms on ut but it had the timing done, do you have any other suggestions please?? Jazz


... 1998 Suzuki Swift

I have a ford explorer 1996 it turns over but wont start its happened about 4 diffrent times it can last from a day to a week i have gotten it towed to a mechanic twice each time by time it gets there its fine they cant find any problem starter is fine battery is fine he even checked wth gas pump gauge it read fine but when it wont start it is not getting gas it is fuel injected its driving me nuts its not reliable i dont know if it will start or not


I HAD THE SAME PROBLEM IT SPENT A WEEK IN THE SHOP AND THE CAR WOULD START EVERYTIME. I BROUGHT THE CAR HOME AND READ ALL I COULD ON THIS PROBLEM.\015\012IT WAS THE IGNITION RELAY $7 TO $15 AT ANY PART STORE. IN THE MAIN POWER BOX ON THE DRIVER ... 1996 Ford Explorer

Fuel injector fuse keeps blowing and car wont start. Think I need to replace injector(s). Put in a bigger fuse and it gets hot. Still wont start. Can't hear fuel pump humming either.Suppose I need to remove injectors and check resistance with ohmeter.


... 1999 Pontiac Sunfire

Wont start Hay guys, im having a nightmare with my civic. PLEASE HELP!! i got a 1996 1.4i Honda civic was driving it one day i was in 4th gear then all of a sudden it just lost all power and cut out. it tries to start but just wont fire up. it has spark so plugs and distributer are fine, the fuel pump is working fine fuel is getting to the rail ok, ive changed the injectors but still no joy. Any ideas on what it could be, where its located and how to resolve it? i have some knowledge with


Sound like a bad main relay, If the distributor is good as you said then the main relay is at fault. This relay control the injector pulse. To check to make sure that the injectors aren't working by using a can of intake cleaner, spay in ... 1995 Honda Civic
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 4.5652 seconds