Having problems with your 1992 Chevrolet S-10 ?

The transmission for the 4wd is kicking in but the hubs are not locking in what could be the problem?

Posted / edited by AnonymousUser on : 18-12-2017

Answers :

Dirt is the #1 problem - and lack of lubrication.
Remove the hubs - clean - and re-pack with grease.

Thanks!!
Your truck is a 1992 and generally I see these go out upon 8 to 10 years old. the reason is the seals go bad and dirt will get inside destroying the working parts. Aftermarket hubs are generally seen at a far better price than GM prices if replaced. Take off your old ones and clean them in a solvent. Check and see if all parts are intact and clean. The seals can be purchased separately at the dealer. Most of the time the original bolts will shear off so plan on that to happen. I would soak them overnight with a penatrating oil with a fast acting catylist also so they remove somewhat easier
Repair Help & Product Troubleshooting for 1992 Chevrolet S-10

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0083 seconds