Having problems with your 1989 Chevrolet Camaro ?

I changed the mass air flow sensor, car still don't want to start, when you disconnect the sensor car starts give it gas it runs great, when you still have car running and hook up sensor again and give it gas it wants to stall. What is causing that problem?

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

It sounds like you have a problem with your TPS (throttle positioning sensor !!!
Is the sensor new?
\015\012check the wire from the very root of the air mass sensor wiring to the sensor its self.
\015\012
\015\012it sounds like either the air mass sensor is at fault or the wiring is touching somewhere.
\015\012
\015\012Regards
\015\012Dan
Repair Help & Product Troubleshooting for 1989 Chevrolet Camaro

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I changed the mass air flow sensor, car still don't want to start, when you disconnect the sensor car starts give it gas it runs great, when you still have car running and hook up sensor again and give it gas it wants to stall. What is causing that problem?


It sounds like you have a problem with your TPS (throttle positioning sensor !!! ... 1989 Chevrolet Camaro

My car is acting like it wants to run out of gas every time i go over 45mph.. when i stop at a light or stop sign, before i get ready to go the car dies, i learned to fix the problem about when i stop.. i give the car a little gas while my foot is still on the brake to give it a little umph.. when i get ready to go.. help me... i brought it to an auto shop and talk to many mechanics.. they said it sounds like my throttle sensor..is that what it is?


I had the same problem! It took me 2 fuel filters to fix the problem temporary. Finally I ended up replacing the entire fuel pump (a mechanic told me one of the prongs holding it in was broken?) No problem ever since though! ... 2002 Pontiac Sunfire

I have a 2001 VW Beetle, there are about 95,000 miles on it. When I start the car and give it some gas it shakes really hard and the RMP needle just goes up and down. If I let it run the car shuts off or sounds like it is running really hard. I have replaced my mass airflow sensor twice and taken it to a couple different places to run a diagnostic but nothing comes up on the reading. I thought it might have been moisture in the gas tank, even after I put some Heet into it, it still does this...a


If you have not replaced the timing belt it could have jumped time and you must replace it before something disasterous happens. ... 2000 Volkswagen Beetle

1993 Buick Roadmaster with 66,000.00 original miles. Something going on with maybe the charging system. When driving the car want's to cut out but giving it gas keeps it going. The RPM goes up and down whiling cutting out and coming back. Happens constantly. Car still runs very good. We ended up driving home to MI from KY this way. Drove semi ok on hwy. Still did the charging prob. but if kept at 55 no slower or faster...not so bad but still present. battery is good, starts great, used gas treat


Sounds like a voltage regulator....while running at a constant speed ..if things start shutting down...a/c stops, radio gets static,wipers slow..etc...the alt isn't suppling the juice needed so it takes from the batt...when the batt starts getting lo ... 1997 Buick LeSabre

I have a 98 vw golf it starts and runs but wants to shut off when given gas. let off gas car idles fine so i unpluged the maf sensor and i can give it gas without it wanting to shut off. could the sensor be the prob?


... 1998 Volkswagen Golf

After replacing the MAP sensor, the Throttle position sensor, the fuel filter, and gas cap-changing the oil, adding Gumout, octane booster, the car still wants to hesitate while first accelerating on the highway or stall when first running after shutting down. If we gun it in neutral, it will not stall... and the gas cap, though new, still has no vacumn when releasing the pressure taking it off. I suspect that there is a hose leak, crack, etc. My son checked it, but that is all that seems to be


What year & engine on this vehicle? ... Plymouth Grand Voyager

Dodge 03 My car jerks whenever I press the gas pedal. When I am driving and let off the gas it runs smooth but as soon as I give it a little gas, it jerks again. The check engine lights on and it said something about the sensor cam so i had that replace along with something else i dont remember still no help then they change out the fuel pump still doing the same or maybe even worse please help i thing they keep telling me things are wrong cus im a single mothr of 3 and will to do anything to fi


Check the air flow sensor jack or the sensor itself it may be damaged or broken this causes the car to **** because this affects the fuel to gas mixture. ... Dodge Stratus

I have a 1997 Buick LeSabre. Check engine light came on, stalls at stop lights, dies while driving. Hooked it up to a diagnostic, said PO 102. Went to the junk yard, took a MAF off a running car, hooked it up, reset the computer and same thing. I bought some car cleaner, shot in the intake, changed the air filter.. still does the same thing. I seem to be flying through gas as well. What should I do next? Mind you, I'm a single mother, who knows a bit about cars, but I'm wanting to fix this m


Your doing it the right way by heading to the junkyard. I go there as much as I can to find parts. MAF sensors are fairly fragile and if the car you removed it from was wrecked, it could have damaged the sensor. I always suggest removing and cleaning ... 1997 Buick LeSabre

1996 Achieve runs sluggish up hills,check engine light blinks, poor gas mileage, smells of gas, wants to stall out, has stalled out, will only restart if sat for about 20 minutes, runs fine when cold out. Ok, those are the problems I am having, here is the specs. of the car..It is a 1996 Achieva SC 3100 V6 motor, has the Computer Controlled Coil Ignition(C3I). We have changed the Ignition Control Module, the Engine Coolant Temp. sensor, the PVC senor with no luck problem is still there. The comp


When the check engine light flashes it means there is a misfire in the ignition system.Unfortunately you replaced the ignition control module first which is the more expensive instead of checking the plugs,plug wires ,and coils first.If you have an o ... 1996 Oldsmobile Achieva

I recently purchased a 2001 mercury cougar and it has an a DTC code P0340 faulty cam position sensor, out of time. I replaced the sensor and it did not fix the problem. The man I bought the car from had recently replaced the timing belt could it be that he tightened it down to much or not enough or maybe he was off by a tooth when he installed the new belt. The car runs great except when I give it alot of gas it wants to stall.


Unplug the alternator and see if the problem stops, if so replace it, a short inside the alternator can cause this problem, however still test good, and keep the battery charged and cause the computer to throw this code. Its possible the belt is a t ... 2001 Mercury Cougar

Just replace maf sensor on my 2.5s and was running fine then all of a sudden car wants to stall out but when giving gas will run just fine


Sounds like a vacume leak. Can you hear any sucking sounds? ... 2002 Nissan Altima

Car runs fine at idle when givin gas it breaks up bad and the cat. converter turns red replaced the cat. put in new plugs and changed cam sensors car still does the same thing but gives no code


Catalytic Converters run very hot only when too much fuel used.Find the cause of overly rich fuel condition. Over fueling will also cause running problems you are experiencing.You need to check the Short Term Fuel Trim with a ... 2000 Lexus ES 300

5.0 fuel injected tpi 88 firebird replaced fuel pump map sensor and now the vehicle will start and idle great i can give it gas and will continue to run but excessive gas was leaking on manifold. i took apart plenum and runners and fuel rail and 3 fuel injectors appear to have been replaced by previous owner and o-rings appear to be new. Fuel pressure regualator also appears to have been replaced. I checked injectors while still hooked up and they appeared to be firing and i checked the socket a


Hi, Even though the Pressure Regulator has been replaced,It could have a raptured Diafram. Check to make sure your fuel return line is not Plugged, Other possibilities are Leaking Injectors or Damaged. Also check your Throttle body gaskets and Fuel F ... 1988 Pontiac Firebird

I have a 99 Cavalier and the problem with my car started all of a sudden. I can to stop and then my car would no l;onger move in drive, will go in reverse so i changed the transmissiom filter and put new fluid it. still will not move in drive. so i jacked the car up pulled up the e break and put in in drive and give it gas and the will wanted to go. so i let the car back down off the jacks and the put in drive ans give it gas and the car did not want to move in drive. so the i put it in reverse


... 1999 Chevrolet Cavalier

Give gas to car and it seems like trany is slipping but when blinkers were not working car was runing good got blinkers to work some how now car doesnt want to run good when i give it gas car seems to rev up and then go down car sometimes oil light wants to turn on dosnt need oil check ingine light is on


The best thing to do is to get the computer scanned so to see what codes are in memory and why the check engine light is on. this will pinpoint you to the trouble area and take all the guess work out of it and keep you from wasting time and money. ... Hyundai Sonata

I have a 1987 buick century 3.8. The car gives me a code 34 and cannot figure out why. I have replace the MAF sensor with a new one but still gives the code. I take the whole air assembly off of the car and the car runs better. With the air assembly and the sensor plugged in it runs bad and it is burning fuel like crazy. I was wondering if it could possibly be a bad fuel pump not delivering causing the computer to adjust while throwing everything else off being the car is in safety mode right no


I would replace your fuel filter, get cold air intake or just a k&N filter which gives you better gas mileage and more power and keeps engie a tick cooler. \015\012Double check any vacuum leaks. Test the wires to the MAF with an ohmmeter. W ... 1987 Buick Century

I have 1995 Eagle vision. The other morning I started the car up to bring my bf to work. I noticed the oil light was on it normally goes off but this time no. We got maybe 6 blocks and the gas pedal wouldn't work. I would give it gas but it wouldn't go. There was gas in the car. I turned the car off it was still running. When I checked there was no oil but Oil was added and still no luck we can't even get the car to restart . We have tried everything except the starter. Is it possible that the


Most of the time, when it is run without oil it is done with. You don't have a reset button. Will the engine turn over and try to start? If it turns over then you have a chance of getting it running. It wouldn't be the starter, With the car still run ... 1995 Eagle Vision

I have a 1997 Ram that i just picked up. Car ran great during test drive but vehicle was already up to temperature. Its running at about 200. When i cold start the vehicle it will idle but when i put it in gear to drive when ever I stop it wants to stall or will if i dont give it a little gas. The minute the truck reaches temp the problem is gone. Any ideas truck has new plugs, wires, coil. Thinking maybe idle control, throttle sensor? any ideas. thanks


Well youre in the right area check with the dealer there may be a sensor for the cold mode like a choke that is not working ... 1997 Dodge Ram 1500 Club Cab

1993 mazda protege 1.8 sohc. runs good cold but when warm spiratic idle wants to die and hesitates when give it gas. replaced o2 sensor and maf problem still there


You got a vacumn leak either a hose or the intake gasket ... 1993 Mazda Protege

Car idles rough and stalls when giving gas, I replaced plugs, wires throttle position sonsor, and mass air floe sensor I have a 99 Pontiac grand am, just replaced the fuel pump and the car runs good but when after I come to an idle at lights etc and as soon as I give it gas it starts to die and sometimes does die. Check engine light is and it does restart immediately. I have a suspicion that it is some kind of sensor..any ideas?


Have you ever changed the fuel filter? If it's not that, and it's not a vacuum leak, it is probably your idle air control valve. ... 1999 Pontiac Grand Am GT

2002 pontiac grand am wants to stall when driven for about 1hr straight....I changed the coil pack, the crankshaft sensor but it still runs the same and I can smell gas all the time when standing outside of the car....I also changed the fuel pump....


Might be transmission happen to me once ... 2002 Pontiac Grand Am

Hello. I have a 1997 chrysler cirrus lxi and it starts rough sometimes and you have to give it gas to clear it up. Sometimes it will start and die. I just had the crank sensor replaced on it and still doing it. I jabs noticed that when u start it the ciggarrette lighter will make the noise that it is kicking off. It does have a security system on it to where if it is started when the alarm is going off it kicks the fuel system down. Now the car runs great. I am really upset that I cannot figure


... 1997 Chrysler Cirrus

I can only start it with starting fluid. then it will run for a minute and as i give it gas it will cut out and die. now i just bought the car but the people before me had the air intake taped to where it hooks to the fuel intake. the tubing goes straight to the intake. i need to know is thier suppose to be a sensor or some kind of adapter that regulates how much air it takes in.


If the car starts with starting fluid, its a fuel issue. the incoming air is regulated by the idle control valve when the throttle body is closed. other than that the only thing regulating the incoming air is the throttle body/gas pedal ... 1991 Honda Civic

I had a cylinder 5 misfire on my 2002 chevy Camaro v6 3.8. I changed the spark plugs and the spark plug wires and the car runs great, until i give it alot of gas. If i accelerate too quickly now the car acts like it wants to shut down and starts jerking. If I let off the gas she runs perfect. No service engine light comes on anymore either but my code reader shows a yellow emissions light now. do I just have to run it longer or is it a fuel problem? Any clues?


Sounds like spark plug coil is bad. had the same problem on my truck also. check wich cylinder is misfiring and replace the coil and maybe the plug also. if the plug looks good leave it. autozone can give you a read out. when checking the coil, ... 2002 Chevrolet Camaro

2002 Kia sportage running ruff found injector wire chewed off replaced injector wiring harness now won't start unless give gas and dies when u let off gas checked codes found code 1505 and 1507 changed iacv and ect sensor still won't start without giving gas and still dies.


... 2002 Kia Sportage
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 4.2474 seconds