Having problems with your 1988 GMC S-15 ?

1990 S-15 PU 2.5

\015 Starts up and runs about 5-10 min's then shuts down have to what 1-2 hours then it will start up and does the same thing again???\015 Posted / edited by AnonymousUser on : 22-01-2018

Answers :

I have a 1989 GMC s15 4x4 i had the same prob. it would run longer then 5 min. though maybe a halfhour. after pulling out my hair for a week and taking it to the dealer which told me " theres nothing wrong we can find " i discovered the ignition modual under the distributor cap was the problem. i recommend to replace with A/C delco part. i tried the cheap one and had to replace it again.
Repair Help & Product Troubleshooting for 1988 GMC S-15

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Can anyone tell me what these engine fault codes refer to on a 1998 mercedes c180 auto,1.8 petrol. I suspect it may be releated to tempeture sensor. Total of 6 codes 065 (2,2,0,41) resistance too high 104 (2,2,0,68) resistance too low 122 (2,2,0,7a) resistance too low 126 (2,2,0,7e) resistance too low 129 (2,2,0,81) resistance too low thanks jim 161 (2,2,0,a1) resistance too high


Most common is o2 sensor ... 2002 Mercedes-Benz C-Class

03 gmc envoy with 5.3 140000 miles. Oil pressure reading fluxuates between 0 and 40. When problem first started pressure read 80. When vehicle was new it stayed at midpoint (40) vehicle has plenty of oil. if you rev engine or increase rpms it goes to 0 and stayes there. let off and it jumps around like it did when started (0 to 40). No engine pecks while running. Display indicates low oil pressure and stop engine. orange light (check gages) comes on when at 0. any ideas. Service engine has not c


There may be a loose wire or the gauge or sending unit may be going bad. The first thing I would do is to hook up a temporary oil pressure gauge, not using the old one at all. With this watch gauge while driving and see what readings you get. If the ... 2003 GMC Envoy Xl

Hyundai sonata 2000 gls. v6. HAs no EGR. Emission test, first try, HC(0) CO (0) nox 1033 mechanic said my engine seems hot (there was also heat out of vents blowing out. I cleaned my maf sensor and put on high octane gas and fuel cleaner drove for a week and retested. ssecond try HC(0) CO (0) nox 1250. failed agian. I changed my mass airflow from anotehr car and change my 3 front spark plugs myself not the three at back. Car seemed to be running better and engine definitely cooler no mor


... 2000 Hyundai Sonata

I have just purchased an Antler cabin bag with a TSA lock, should be preset to 0 0 0 as per factory setting & I should be able to open it, unfortunately this is not the case, any suggestions????


... Cars & Trucks

The oil pressure gauge is going directly from 0-80.....as soon as you crank up the vehicle....Its running fine, no lights have come on, running smooth like normal, its just that the gauge in the dashboard is going from 0-80....what could this be ....this is the gauge that has 0-40-80 and the picture of the little oil container


It sounds like there is a problem with the oil pressure sending circuit. The oil pressure sender changes voltage according to the differences in oil pressure. If it is pegged all the way to the max, there may be a short (or open, depending on the w ... 2003 Chevrolet Tahoe

97 gmc suburban, no start, has spark and fuel. no codes. scanner shows no problem, except cam ******=0 knock ******=0 and spark ******=0 doesnt show inj. pw. leaning towards pcm??any help would be great


... 1997 GMC Suburban

1990 toyota 4 runner Gun timing mark?? 0 or degrees after 0??


... Toyota 4Runner

1990 corvette tachometer problem, when the key is turned on the tach needle moves from slightly below 0 up to 0 but does nothing more when the engine is started and revved up


... 1990 Chevrolet Corvette

Fitting 0-320 cylinders on 0-290 lycoming


\012You may have this\012posted in the wrong product category. Please select another category\012appropriate to the problem and re-post the problem so the correct\012expert will see and respond to the question.. \012\012This is for ... Cars & Trucks

Frieghtliner m2 fault codes eng 0, 4376, fail 5 and eng 0, 3361, fail 05


... Cars & Trucks

Oil pressure gage is at 0. should be at 30. how do you check to see if it is the pump or sensor. it used to be at 30 or so when it is running, now at 0. how do I check the sensor, or do I have to change pump..


Run a test light from the positive battery terminal to the connector on the sensor. with the engine running, the light should light up. ... 1988 Chevrolet Blazer

C180 merc using lot of fuel co reading 0,also hc 0 ,diagnostic tool showing airflow meter fault could this cause problem


Could be ,also could have a leak in the exhaust ... 2002 Mercedes-Benz C-Class

2006 dodge charger, er code p0406, check egr harness for 5v power on yellow with pink wire and no voltage 0 car is idling a little rough and has slight hesitation when accelerating.replace egr before i found 0 voltage.Also would like a diagram of the relay locations in the fuse box.there are 4missing relay plug sockets


Every fuse box has empty slots, so that is not the issue, this problem is this, the "EGR valve position sensor high signal return detected", this means that the EGR system is working, just the fact it generat ... 2006 Dodge Charger

My oil gage drops to 0 and then back up to 40 when i am on a incline after the car has come to a complete stop or when i am making a turn when it drops to 0 the checks gages light come on and then right back off what can be causing this


First thing, have you check the oil level, maybe its low?if the oil level is ok, when was the last time the oil was changed. could be the oil is too old. last thing, possible low oil pressure due to an internal engine problem. (bearing wear) ... 2005 Chevrolet TrailBlazer

2005 CHEVY COBALT THE ODOMETER DISPLAY READS EITHER 0 MILES OR BLANK. IF THE BATTERY IS DISCONECTED IT WILL READ UNTILL THE KEY IS OFF THEN ITS BACK TO 0


Oh that's a first I never heard that one before. I bet u have an electrical problem. The 2005 and 2006 Cobalts are notorious for a wide range of problems. I guess GMC couldn't work out the bugs. If your car is still under warranty you might want to t ... 2005 Chevrolet Cobalt

I have a 98 plymouth voyager se 3.3l auto (4 speed) and the speedo bounces cause the vehicle to have a jerking motion. when the speedo stays a 0 the vehicle runs fine but this doesn't last long befoer the speedo bounces. it also bounces when you are not moving the bouncing goes from 0 to 200 and when moving its between 20 and 80 . any help would be appreciated We have the same problem and had the speed sensor replaced three times. That was not the issue. Now when sitting at a stand still the sp


I would suggest taking it into a Jiffy Lube or Another Auto-Repair company. They can fix it for sure, and if they don't, you get a refund, and an apology. ... 2000 Plymouth Voyager

86 Jeep GC, while helping a friend pull his pick up out of a ditch, my oil pressure drop to 0. I added some oil and the pressur came back up for a little bit then drop to 0 again.


To check the level of oil in the oil bread if it is correct you can replace the oil filter and if this does not improve it has that remplazar the oil pump ... 1993 Jeep Grand Cherokee

Car came in no start-doa. replaced distributor pick up assembly. car ran but hesitated between 50-60 mph. replaced wires plugs,cap,rotor button, air filter. car runs, after about 4-5 min. driving car shuts down no throttle. let sit a few seconds, car starts and repeats problem. before tune-up pcm threw a mis-fire cyl#1,cleared code. no mis-fire code no hesitation just shut down problem with no engine lite. datastream shows cyl#1 0 misfire,cyl#2 0, cyl#4,5 &6 show high misfire rate. not famil


Have you replaced the fuel filter? what is the fuel pressure?, this sounds like a loss of fuel pressure issue, that would account for the miss fire codes, to check fuel pressure look at the top of the engine, in the fuel supply pipe that plugs to the ... Chrysler Cirrus

Speedo bounces 1994 Toyota Scepter (Camry). Speedo sits on 0, when I drive over a bump or ease off the gas it bounces up to correct speed. Re-accellerate and it goes back to 0. Is it electrical or other?


Yes is elctrical . a small part on the side of the transmision caled speed sensor sending unit replace it ... 1994 Toyota Camry

The oil pressure gauge on my 2004 chevy avalanche is bouncing all over the spectrum, from ''0''-''80'' PSI without any affect on the performance of the engine. The needle will usually peg at 80 PSI, or drop to 0 and then stay there. Inclines and declines seem to have some affect on it as well. What could be causing this?


It is probably the gage cluster. chevy has had a problem with this and it was recalled. so you might go to your dealer and ask him if they will replace the cluster. mine did that to but as time went on all the other gages went crazy or stopped workin ... 2004 Chevrolet Avalanche

I have a 92 plymouth voyager that while I'm driving the instrument gauges will go crazy then everything thing will ping out to 0. What I mean is it will say I have no gas and though I am traveling at 55mph it will say that I'm at 0 is there a reset on this or do I have to repace the instrument cluster?


On-board computer needs to be re-booted.  This is done by disconnecting battery - just the negative post is sufficient - then re-connecting and starting the vehicle.  \015\012\015\012My 1992 Voyager did this for the first time after I ... 1998 Plymouth Voyager

Overhaul of the top in of 2003 jeep 4.7. It had jumped time, broke a valve spring and bent a valve. After the overhaul oil pressure at idle drops to 0 after the engine warms up. No engine noise what so ever. pressure jumps up while driving, but at idle drops back to 0. Afraid to drive, what should I do?


First thing you need to do is put a mechanical gauge in place of oil sender and read actual oil pressure. If mechanical gauge shows same condition, take a look at the connecting rod bearing serving the cylinder where the valve bent. If the piston hit ... 2003 Jeep Grand Cherokee

I have a 98 plymouth voyager se 3.3l auto (4 speed) and the speedo bounces cause the vehicle to have a jerking motion. when the speedo stays a 0 the vehicle runs fine but this doesn't last long befoer the speedo bounces. it also bounces when you are not moving the bouncing goes from 0 to 200 and when moving its between 20 and 80 . any help would be appreciated


Replace the vehicle speed sensor, I am sure this is the cause of the problem, about $40.00 for the part ... Plymouth Voyager

Electrical Problem All my gauges (fuel, rmp, speed) are stuck, and the led odometer quit displaying, except for large 0. even when I turn the car off, the led 0 stays lit. Can anyone advise how to fix please?


I have no horn but the fuses are ok also i have no cruise control ... 2000 Chrysler Grand Voyager

ELECTRICAL PROBLEM my truck runs fine now the bat gage is at 0 my oil gage is at high they were working fine i was hooking up a new stero looked up the gages for alt at 0 the oil was at high the heat was at normal the gas gage was at the proper level the only problem im having now is the battery gage and the oil gage the truck now runs with the neg cable off so alt problem is good any thoughts.


The prob seems like you have connected the power to your stero from the wrong place. You cut into live a wire for the power, this should be connected at the ACC on your fuse panel. Also make sure you stero has a good ground! Frankster016 ... 1989 Ford F 150
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 3.2068 seconds