Having problems with your 1988 Ford F 150 ?

Wont pass smog runs to rich at a idle - 1988 Ford F 150

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Repair Help & Product Troubleshooting for 1988 Ford F 150

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Wont pass smog runs to rich at a idle - 1988 Ford F 150


... 1988 Ford F 150

Wont pass smog runs to rich at a idle but runs great


... 1988 Ford F 150

The car is running rich and wont pass smog - 1986 Ford Ranger 2WD


... 1986 Ford Ranger 2WD

2003 tahoe fault code p0101 maf vaf ckt range/perf p0300 random multiple misfire detected p0420 catalyst eff below threshold bank 1 p0172 sys to rich bank 1 truck suddenly started to run poorly, has little to no acceleration & wont hold an idle. recently have replaced plugs, wires, air and oil and fuel filters with no help. cleared all above stated codes only to have the first two listed return. truck still runs bad.


For p0300 ,p0240 on chevy tahoe 00- 06 check a wire going along with the battery ground to the engine block thre should be a high resistence on the small wire ,it gets corrode over time ,it should be located on underneath of the driver side engine, ... 2003 Chevrolet Tahoe

Carbuator 87 Plymouth Colt E Import wont pass Ca Smog. told running 2 rich. Nothing done 2 motor other than basic tune up.Passed Ca. Smog W/flying colors last year. Need 2 know where adjustments on carb R so I can Adjust 2 pass. Please help...


... 1987 Plymouth Colt

I have a 1992 Ram with a 5.2 that is running rich and blowing black smoke. Runs great, a lil rough, but wont pass smog and has NO CODES to pull? It looks like the cap, plugs, oil, o2 sensors, cat, and


Check the engine coolant temperture sensor just replaced mine on a 2001 durango ... Dodge Cars & Trucks

91 ford f150 4.9 runs rich blows out black smoke runs rough and wont idle right have to rev up motor


Check airflow or possibly o2 sensor(s) ... Ford F-150

I have a 99 ram 1500 5.9L that is running rich and wont pass smog. ive replaced the 2 o2 sensors, plugs, wiers, dist. cap, roter, air filter, and canged the oil. it dosent have any codes jus rich. what else could it be?


I have heard that if you run the **** out of it before taking it in it will pass ... Dodge Ram 1500

2000 ford contour number 1 and 4 cylinders running lean and number 2 and 3 running rich. Has a rough idle and hard time accelerating.


Have the fault codes read. Replace faulty items. Use onlygenuine items as replacement as non-genuine are not always compatible with the OEM fitted CPU units. This results in the fault codes not cancelling out. ... Cars & Trucks

How can I fix the engine from running rich? It runs so rich. It doesn't pass CA Smog? How can I isolate the problem? Also the car has been sitting in driveway for a couple years. But I started it for first time in two years and it started on first try. It runs just like it did two years ago I really want this car to pass CA Smog. The car is a 1990 Pontiac Grand Prix LE 2.4 Please help have a lot of family memories in that car! Thank You, Johnny Anglen


This is what i did when my 89 chevy beretta failed and the guy handed me a pamphlet on turning in your junker car for a $1000...and he was kind of laughing like you failed and i got you money anyway because he thinks he knows that there's no way my c ... 1990 Pontiac Grand Prix

I have a 92 toyota paseo with auto trans it runs fine cold after it warms up its sluggish, idle goes up and down, it wont pass smog due to double the hydrocarbons


Check for a vacuum leak. open the hood, you should be able to hear a hissing sound. track down that sound and repair it. ... 1992 Toyota Paseo

I have a 1999 gmc suburban k1500 5.7 vortec it has a throttle body injector it has started to miss at about 4000 rpm runs fine throught the rest of the rpm range it misses no matter the temp i have changed the cap rotor wires plugs are less than 1 year old new coil and high flow air filter can any one help as it stands i can not pass because it pretty much wont accel past the 4000 rpm mark just stays there n misses no problems with idle or reving it up in park or neutral and dose the throttle bo


Check the fuel pressure and the fuel filter. You've eliminated the ignition probables. ... Cars & Trucks

Wont pass smog running to rich - 1990 Honda Accord


Plugged EGR ports. Ask Honda for EGR Intake cleaning ports kit. ... 1990 Honda Accord

My truck is running rich and wont pass smog. i have made sure timing is good and no vacuum leaks and replaced the o2 sensor. what else can I check?


Install a new catalytic converter and check your air filter ... 1989 Ford Bronco

I HAVE A P0300 OBD CODE I DID A COMPRESSION TEST TO ENGINE AND IT PASS THE TEST,I DID CHECK EGR VALVE,CHANGE SPARK PLUGS,IGNITION WIRES, CAP AND ROTOR, I DID CHECK TPS SENSOR MAF SENSOR,FUEL PRESSURE,AND OXIGEN SENSORSI I FOUND THAT ON BANK 1 BOTH SENSORS (UP STREAM & DOWN STREAM )WORKS NORMALY BUT ON BANK 2 THE SENSOR 1 CHANGE FROM 0 TO 600 MILIVOLTS BUT NO CHANGES FROM RICH TO LEAN &SENSOR 2 HAS 0 MILIVOLTS & NO CHANGES FROM RICH TO LEAN SO I SWICHT SENSOR TO TEST THEM FROM BANK 2 TO BANK 1 AN


... 1997 Nissan Pathfinder

I cant remember what I had replaced about 5-6 months ago, seems like it was a sensor. My 1993 Ford Explorer is not running or idling at normal speed. When I pull up to stop it is like it stays engaged and wont idle down. Then when I 1st start it it wont stay running at all. If I have to be stopped at traffic lights for any amount of time I have to put it in neutral and keep the engine idled up high. Seems like it was the map sensor but then again its almost like it was oxygen sensor.


Listen for a hissing noise(vacuum leak around the pcv elbows or upper intake gaskets) this will cause a high idle set off lean codes which will say bad o2 sensors alson check idle air control valve which is located by throtlle body this wil ... 1993 Ford Explorer Limited

2001 hyundai santa fe with obd 2 code po172 i bought this vehicle and now it wont pass smog


... 2001 Hyundai Santa Fe

After changing head gaskets on my Ford Escape 2002 the starter motor seems to be on all the time ... As soon as the ignition key is the on position the starter will run then when the motor runs the starter motor wont disengage.. Also on the gear indicator on the dash wont display the actual gears that is engaged .. like if i put drive the light for 2 and 1 will turn on ... then when i go to reverse the light for drive and 1 will turn on ...


... 2002 Ford Escape

Evo 1 my evo1 wont idle had problems with battery had to jumb start a few times got new batttery now wont idle car run ok but when i stop it cuts out got told to take battery off for at least a hour reconnect then start up and if car idles leave it idle for twenty min's for the computer to reset itself is this right or is ther another way


It may be the idle air controll motor going bad u should take it to a shop with foriegn experience ... 2004 Mitsubishi Lancer Evolution

Engine light came on truck ran ruff, light went out and it came to life, this happend 3 times in 2 days now it just wont run right, there are 4 plugs, 2 on each valve cover, if i un plug 1 on the driver side the truck almost dies, i do the same on the pass. side nothig happens? the truck still runs the same i checked the amps on both sides, the pass side is way lower amps than the driver side, so its only running on 4 cylinders, my injectors are not comeing on i asume cus of the low power going


Kinda confussed? what plug's are you talking about? the glow plugs? once started it should not make a difference if you disconnect them. the first thing you need to do is get the computer scanned to see why the check engine light came on and that wil ... Ford F-250

Wont idle 1991 Ford F250 Pickup 351 wisner Fuel injected when cold hasn't been started in a day will start and idle real good real smooth when put into gear and go to move will die then when try to start back will not start unless acelator held to floor when does start have to keep pumping acelator to run but wont idle unless pumping


Sounds like dirty fuel check your fuel filters see if ther blocked ... 1991 Ford F250

Have a 1989 f250 5.8 that didnt pass smog the guy told me its running rich the report said the HCdidnt pass just by a few numbers everthing else passed so i put plugs cap wires o2 sensor and a new brake boosterno it runs worse than it did it now surges going down the road like it has a short or a fuel pump problem


Would double check your firing order on your cap.If running worse almost positive some wires were crossed.The spark plug firing order is ( 1 - 3 - 7 - 2 - 6 - 5 - 4 - 8 ) and runs counterclockwise on the distributor cap. ... 1989 Ford F 250

My ford f 150 with a 300 inline six is idling rough but with run, runs good at high rpm but is running rich


I have a 1967 Ford F1oo with the in-line 300 6 cylinder that's running rough what could possibly be the problem The gentleman that I bought the truck from said it would be a burnt valve ... Cars & Trucks

Runs but wont idle. smells to rich. other than that it runs fine


This sound like a vacuum leak... Look carefully for loose/cracked hoses and connections from the fuel distributor/air box to the throttle body and around the idle enrichment bypass hoses... and also the intake gasket itself. The reason it smells rich ... Volkswagen Rabbit

Rich fuel i have a 2000 ford focus and the car runs runs way too rich on fuel you can smell it when you drive. i had it diagnosed and a code pops up that reads 190 what should i do? i cant get the car smogged till this problem is resolved. thankyou for looking and i appreciate it


Change the lambda sensor.or O2 sensor some call it. ... 2000 Ford Focus
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 7.1006 seconds