Having problems with your 1988 Chevrolet Celebrity ?

I have an 1988 chevy celebrity 2.8. while driving, it will just all of a sudden lose power kinda like turning off the key and back on i have replaced ignition module, plugs and wires, mass air flow, map sensor and smacked the ptm and even looked over the wire loom. what could it be? and replaced the throttle ps.

Posted / edited by AnonymousUser on : 22-01-2018

Answers :

Hi Charlie, I suggest you replace the fuel filter and have the fuel pump pressure tested for correct output. Have a diagnostic scan carried out. Regards John
Repair Help & Product Troubleshooting for 1988 Chevrolet Celebrity

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have an 1988 chevy celebrity 2.8. while driving, it will just all of a sudden lose power kinda like turning off the key and back on i have replaced ignition module, plugs and wires, mass air flow, map sensor and smacked the ptm and even looked over the wire loom. what could it be? and replaced the throttle ps.


Hi Charlie, I suggest you replace the fuel filter and have the fuel pump pressure tested for correct output. Have a diagnostic scan carried out. Regards John ... 1988 Chevrolet Celebrity

My Subaru? Hi, I replaced the plugs and wires today. None of the plugs had a white film on them... The car keeps sending the code for a mass air flow sensor which I replaced two days ago. I took the car to a shop and had it looked at by a tech and it said the mass air flow sensor was receiving "high input". I have come to the conclusion that I installed a faulty mass air flow sensor. The car runs really rich and want to stall when idling at a stop light. When sitting at a stop light the car will


I would say that the sensor may be bad the only other thing that i can think of is that the PCM lost its idle settings. then it is trying to relearn the idle setting and adjusting for the air sensor and/or the O2 sensor. ... 1997 Subaru Legacy

I have a 1999 oldsmobile intrigue that is misting a lot. It idels rough, and runs rough. I can still take off it is a little slow, but I can still go pretty fast, but it still mist at the high speeds pretty badly. I have checked the mass air flow sensor, the oxygen sensor, I have replaced all spark plug and spark plug wires, and still nothing. The computer at Autozone said there were three codes on it, Misfire in 4, Oxygen Flow Sensor, and Mass Air Flow Sensor. After we changed spark plug a


Fuel pressure regulator on the fuel rail is probably it or the egr valve is stuck open allowing burnt fuel to flood the intake, im leaning towards the fuel pressure regulator because the o2sensor is probably reading rich or if its reading lean then i ... 1999 Oldsmobile Intrigue

My 1996 sentra is bucking and kicking while driving and dies when idling at lights. I have replaced air, fuel filters as well as wire and plugs. Check engine light does not come on. Fuel economy goes from 32 mpg to approx 20! This happens every few thousand miles and then just stops! Is this possibly the idle control sensor, fual map sensor, mass air flow sensor, or the entire electronic coil system?


... 1996 Nissan Sentra

My 1996 sentra is bucking and kicking while driving and dies when idling at lights. I have replaced air, fuel filters as well as wire and plugs. Check engine light does not come on. Fuel economy goes from 32 mpg to approx 20! This happens every few thousand miles and then just stops! Is this possibly the idle control sensor, fual map sensor, mass air flow sensor, or the entire electronic coil system?


... 1996 Nissan Sentra

Engine runs rough at idle, PO300 comes up, replaced 3 fule injectors, upper intake gaskets, mass air flow sensor, timeing belt, water pump, crank shaft sensor, wires, plugs, cap, roter. when you unplug mass air flow sensor car runs at a high idle 2000 rpms but will run smooth.


P0300 means random missfire. generally that means electrical problem. You replaced cap and rotor. how about the ignition module? this problem can be caused by a loose contact in the ignition system somewhere. Very hard to track down. ... Nissan Quest

Engine runs rough at idle, PO300 comes up, replaced 3 fule injectors, upper intake gaskets, mass air flow sensor, timeing belt, water pump, crank shaft sensor, wires, plugs, cap, roter. when you unplug mass air flow sensor car runs at a high idle 2000 rpms but will run smooth.


Wow thats alot of chasing... have you check the compression of the motor on each cylinder? when did this start and how. can you give me a little more history on that? ... Nissan Quest

I bought a 1997 Mercury Cougar about 5 months ago. The Cougar only has 83,000 miles on it. Since buying it I have had the oil changed, the transmission flushed. I have also had all 4 o2 sensors replaced and coolant temperature sensor. My brother has installed a new intake manifold gasket set, new fuel filter, replaced the spark plugs and spark plug wires. The person who sold the car to me said he replaced the mass air flow sensor and it appears to look brand new. The car has been throwing out t


By your description, I tend to agree with fuel pump issue. Could be something as simple as a connection on the pump -loose ground and/or power wire or an intermittent pump. At 83,00 that's far from being "over the hill" Also just a thought, converter ... 1997 Mercury Cougar XR7

I have a 2002 GMC 4x4 Sierra 1500 5.3L - After starting in the mornings, the engine revs up and then idles very low almost to the point of dying sounding very rough. Runs fine after it warms up. I have replaced the air filter and mass air flow sensor, fuel pump and filter, fuel pressure regulator, plugs and plug wires. Seemed a little better after replacing the fuel pressure regulator. Some say to replace the IAC or the air intake gasket. All codes say misfire.


Is the check engine light on? Does it only rev one then go low or keep reving up and down? Thanks ... GMC Sierra 1500

2002 saab 9.5 2.3 lt turbo the check engine light came on and the car was running rough so plugged in my scanner and got a p106 code map sensor code repaced the map sensor the mass air flow sensor checked for vacum leaks there is none took off the throttle body cleaned it cleaned out the air box replaced dirty air filter and the code will pop up pending right away since weve done the work we have the car is running and idleing really good but the p106 code will not go away any idea


Will your scan tool erase the code. maybe check the( ITA )intake air temperature sensor ... 2002 Saab 9-5

The 94 Buick lesabre would hesitate while driving then died and I replaced the mass air flow sensor and oxygen sensor and the car only runs with the mass air sensor unplugged but runs rough the oxygen sensor said low voltage so I replaced it and Im not sure if the catylitic convertor is plugged but exhaust still comes out but its very hot and it stinks as soon as I plug the mass air flow sensor back in the car dies


Well it sounds like a plugged converter. i use an infer red temp sensor thaT i can monitor the temp before and after the cat to see if it is working. you can also take the upstream o2 sensor out and run it that way to see if you gain the integrity of ... 1994 Buick LeSabre

I have a 1997 monte carlo and the car is always 'dogging' when i accelerate. it takes forever to get the car up to speed. i have a new catalytic converter, a new gas tank. i have also had the fuel injectors replaced, the spark plugs and wires replaced, all the coil packs replaced. the module that the coil packs sit on has been replaced, the crank sensor replaced, the computer replaced, the mass air flow sensor replaced, the throttle position sensor replaced. i have had multiple mechanics look at


Fuel pump ... 1997 Chevrolet Monte Carlo

1990 skylark that sounds like its sucking air when the throttle is pushed. In or out of gear it dies when throttle is pushed but it will idle. I get a mass air flow sensor: low air flow indicated : code. The maf sensor, ecm, fuel pump and filter, spark plug wires, tps and fuel pressure regulator have all been replaced within the last 6 months or sooner. Have checked for vacuum leak and found none.


Check your air intake hose closely for leaks, any cracking will cause this. ... 1990 Buick Skylark

2003 ford windstar problems how to fix..won't run..have replaced plugs and wires,,fuel filter,mass air flow sensor. 2 fuel injectors.replaced 2 clips that control air flow sensor....i do hear it g


... 2003 Ford Windstar

I have lost a lot of power with my 1995 Isuzu Rodeo. This issure was going on when my father gave it to me. I took it to a Honda dealership for repair. It ran great for 3 years and now I am having the issure again. I replaced the spark plugs and wires. New air filter. Cleaned the mass air flow sensor. It looks as if oil is getting in and fouling one or more of my plugs. I went to dealership to ask what all they replaced. The tech said it soulded like my ''rocker seals'' have gone bad. They repla


This is what the print out of the work order says.\015\012" Replaced all 6 spark plugs, spark plug wires, coil pack for 1 & 4. Rrelaces all 6 spark plug gaskets. Replaces timingbelt tensioner. Replaced timing belt and all ext. belts. Servic ... 1995 Isuzu Rodeo

My 1997 ford exporer sport 4.0 L runs very rough. It started out with a slight miss, then worked its way to running so rough that I almost called a tow truck to take it home. Heres a list of things Ive replaced in the last 6 months trying to fix the problem: Crankshaft position sensor IAC Valve throttleshaft positioner sensor mass air flow sensor (checked out ok) Upper and lower manifold gaskets fuel filter (never again!) fuel pump spark plugs plug wires (checked resistance-ok) repl


SOUND LIKE A VACUUM LEAK AT THE INTAKE MANIFOLD.CHECK ALL VACUUM HOSES ON INTAKE.REPLACE FUEL FILTER.COULD HAVE LOW COMPRESSION WORN OUT VALVES. ... 1998 Ford Explorer

I got a p0113 code for the mass air flow sensor on a ford sport track 2001 4.0 litre. I replaced the part but my truck will not run with the sensor plugged in. I can start it with it unplugged but when I plug it in the truck dies. Help? I've been told that it could be a wiring problem...ugh! Any suggestions?


1. At the Mass Air Flow (MAF) sensor connector, backprobe the Gray (GY) wire at terminal #6 with the key on and the MAF sensor connected. Typical voltage will be about 2-3.5v depending on temperature. 2. If the voltage is above 4.5v (whic ... 2001 Ford Explorer Sport Trac

I have a 1988 pontiac firebird with a 2.8 v6 fuel injected engine that displays code 32 and 34. We have changed the plugs, plug wires, rotor, and dist. cap and have also replaced the mass air flow (maf) sensor. All accessible vacuum lines have been replaced as well as the fuel filter. The car runs good, but while the car is idling in park, as soon as you put it in reverse or drive it wants to (and sometimes does) stall. There is also a slight hesitation when reving the engine. What could be caus


Check throttle position sensor (TPS) is a sensor used to monitor the position of the ... 1988 Pontiac Firebird

1997 ford taurus gl 3.0 L V6. replaced spark plugs, wires, and mass air flow sensor. cranks but will not start.all plugs are firing. not sure if wires were put back on distributor rite. to many people helping! do you no the correct order. no numbers available?


... Ford Taurus

Service engine light came on took in for computer read at auto zone got a mis fire in cylynder one said crank sensor replaced crank sensor put new plugs and new wires new oil filter andoil cleaned mass air flow sensor still have miss fire and you can fell it whenyou try to get on it


Cylinder 1 is not firing or is intermittently firing. Check the output on the coil associated with #1 cylinder by using a spare plug attached to #1 wire while engine is running. If it has good spark, check the fuel injector for possible problems. Cra ... 2004 Ford Taurus

I have a brand new mass air flow sensor on a 1991 buick century limited with a 3.3 liter and someone replaced the plug and i dont think they wired it up correctly and i want to know the pin out what color wire goes to which terminal because the new pig tail wires are all white thank you


... 1991 Buick Regal

Hesitation in acceleration, I've taken to dealer 3 times, they said it was mass air flow sensor, replaced it, then throtel possition sensor, replaced it, then fuel pump, replaced it, then fuel pump computer, replaced it, then front o2 sensors, replaced them still no help. DOES ANYONE KNOW WHAT TO DO?? Dealer is stumped, they've checked timing, vacume leaks, ecu and wiring for damage none found, fuel injectors grounds, air flow meter, egr for sticking, ALL NO PROBLEMS,, PLEASE PLEASE HELP!! Thank


... 1995 Lexus Sc 400

98 silverado p0300 miltiple misfire replaced distributor,plugs,wires,egr,fuel pump and fuel filter,o2 sensors,cleaned mass air flow, replaced injector spider assy, im stumped on this


Do you have any other codes along with the 0300 code? If so, it could pin point the problem\015\012 ... Chevrolet C1500

I have replaced egr valve and mass flow air sensor and egr sylinoid and have replaced catylatic converters. Truck still sputters. I have put new plugs, wires, and distributer cap and button. Truck fells like it doesn't have power. Truck is in time. valves chatters when under load or press on gas pedal hard what can i do


I recommend you test your fuel pressure to see if it fluctuates any.If it were to be any of the other sensors you would have a check engine light that would come on.The only system that doesn't have any sensors would be your fuel system ... Ford F-150

My GMC stalls on acceleration. It pings, stutters, cuts out etc. I've replaced the fuel pump and filter, the coil, the distributor, 2 sets of plugs and wires, cap and rotor, the alternator, throttle position sensor, and paid to have the fuel injectors cleaned, and a new mass air flow sensor. At idle, the motor sounds fantastic, as soon as fuel is applied it cuts out unless the fuel is feathered. It has no power under load but like I said, idle it does good. Before it became undriveable the milea


Check for plugged exhaust ... 2001 GMC Sonoma Extended Cab
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 4.2339 seconds